D - Parentheses Balance

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
(a) if it is the empty string
(b) if A and B are correct, AB is correct,
(c) if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your
program can assume that the maximum string length is 128.


Input
The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string
a line.


Output
A sequence of ‘Yes’ or ‘No’ on the output file.


Sample Input
3
([])
(([()])))
([()[]()])()


Sample Output
Yes
No

Ye

题意:输入N,然后输入N组数据,对于每一组数据判断每一个“(”和“[”是否存在一个“)”和“]”与之对应,存在输出“Yes”否则输出“No”。

解题思路:用栈模拟,循环判断,如果是“(”和“[”,进入栈,遇到“)”和“]”判断栈顶元素是否与之对应,对应则出栈,不对应则结束循环,输出“No”,如果全部字符判断完成,栈空并且不存在匹配失败情况,输出“Yes”。

错误原因:题上存在空字符串情况,%s读取可能无法读取全部数据,用gets读取过了,但是第一次选择提交的语言不支持gets,编译错误,换成c++11 5.3过了。

#include<stdio.h>
#include<string.h>
int main()
{
	int i,j,k,m,n;
	int l;
	char s1[200],s2[200];
	while(scanf("%d",&n)!=EOF)
	{
		getchar();
		while(n--)
		{
			int f=1;
			//scanf("%s",s1);
			memset(s1,0,sizeof(s1));
			memset(s2,0,sizeof(s2));
			gets(s1);
			l=strlen(s1);
			m=0;
			for(i=0;i<l;i++)
			{
				if(s1[i]=='('||s1[i]=='[')
				{
					s2[m++]=s1[i];//入栈
				}
				
				if(s1[i]==')')
				{
					if(s2[m-1]!='(')
					{
						f=0;//标记比对是否成功
						break;
					}
					else
					{
						m--;//栈内元素减一
					}
				}
				if(s1[i]==']')
				{
					if(s2[m-1]!='[')
					{
						f=0;//标记比对是否成功
						break;
					}
					else
					{
						m--;//栈内元素减一
					}
				}
		/*		for(j=0;j<m;j++)
					printf("%c",s2[j]);
				printf("\n");*/
			} 
			if(f==1&&m==0)
			{
				printf("Yes\n");
			}
			else
			{
				printf("No\n");
			}
		}
	}
	return 0;
 } 
  
  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值