M - A Mini Locomotive POJ - 1976

A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows: 

1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives. 
2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches. 
3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1. 

For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60. 

If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers. 

Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives. 
Input
The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the i  th number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches. 
Output
There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.
Sample Input
1
7
35 40 50 10 30 45 60
2
Sample Output
240

题意:给你三个车头,每个车头能拉n节连续的车厢,问最多能拉多少人。

思路:背包问题,将连续的n个车厢内的人看做是一个整体,根据方程s[i][j]=Max(s[i-1][j],s[k][j-1]+b[i]),对于连续的n节车厢内的人要么放到车头后边,要么不放,如果当前连续的n个选择放入,则跳过这n个从后边的车厢开始。


#include<stdio.h>
#include<string.h>
int Max(int x,int y)
{
	if(x>y)
		return x;
	return y;
}
int main()
{
	int i,j,k,m,n,t;
	int a[50100],b[50100],s[50100][5];
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			memset(a,0,sizeof(a));
			memset(b,0,sizeof(b));
			memset(s,0,sizeof(s)); 
			scanf("%d",&n);
			for(i=1;i<=n;i++)
			{
				scanf("%d",&a[i]);
			}
			scanf("%d",&m);
			
			for(i=1;i<=n-m+1;i++)//M辆车为一组 
			{
				for(j=i;j<=m+i-1;j++)
				{
					b[i]+=a[j];
				//	printf("i==%d  j==%d\n",i,j);
				}
			}
			
		/*	for(i=1;i<=n-m+1;i++)
				printf("%d ",b[i]);
		*/
			for(i=1;i<=n-m+1;i++)
			{
				for(j=1;j<=3;j++)
				{
					k=i-m;//k刚开始可能会比i大
					if(k<0)
						k=0;
		//			printf("k==%d\n",k);
					s[i][j]=Max(s[i-1][j],s[k][j-1]+b[i]);
				/*	for(int x=1;x<=n-m+1;x++)
			        {
			        	for(int y=1;y<=3;y++)
			        	{
			        	
			        		printf("x==%d  y==%d  %d\n",x,y,s[x][y]);
			        	}
			        
			        		
			        		printf("\n");
					}*/
				} 
			}
			printf("%d\n",s[n-m+1][3]);	 
		}
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值