Find a way(HDU2612) 两次BFS

Problem Description

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input

The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4
Y.#@

.#…
@…M
4 4
Y.#@

.#…
@#.M
5 5
Y…@.
.#…
.#…
@…M.
#…#

Sample Output

66
88
66

思路:

进行两次BFS,将两个人走到一个点的时间分别记录。
但是这道题有一个需要注意的地方:只有两个人都能到的KFC才能被记入最短时间。
至于M,Y能否经过Y、M,我提交了能经过和不能经过的代码,结果都AC了,所以这个条件应该不用去管。

#include <bits/stdc++.h>
#define mem(a,n) memset(a,n,sizeof(a))
#define maxn 205
#define inf 999999999
using namespace std;

char maze[maxn][maxn],cc[2]={'M','Y'};
int cost[2][maxn][maxn],n,m;//记录花费的时间,第一个下标0表示Y,1表示M
int dir[2][4]={{0,0,-1,1},{-1,1,0,0}};//上下左右,先x后y
bool vis[maxn][maxn];

void bfs(int x,int y,int s)//s 表示Y还是M的BFS
{
    queue<int> qx;
    queue<int> qy;
    int nx,ny;
    qx.push(x);
    qy.push(y);
    mem(vis,0);
    while(!qx.empty())
    {
        x=qx.front();
        qx.pop();
        y=qy.front();
        qy.pop();
        for(int i=0;i<4;i++)
        {
            nx=x+dir[0][i];
            ny=y+dir[1][i];
            if(nx>=0&&nx<m&&ny>=0&&ny<n)
                if(maze[ny][nx]!='#'&&!vis[ny][nx])
                {
                    cost[s][ny][nx]=cost[s][y][x]+11;
                    vis[ny][nx]=1;
                    qx.push(nx);
                    qy.push(ny);
                }
        }
    }
}

int main()
{
    int x1,y1,x2,y2,ans;
    while(cin>>n>>m)
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
                cin>>maze[i][j];
                //记录Y和M的起始位置
                if(maze[i][j]=='Y') {x1=j;y1=i;}
                if(maze[i][j]=='M') {x2=j;y2=i;}
            }
        ans=inf;
        mem(cost,0);
        bfs(x1,y1,0);
        bfs(x2,y2,1);
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
            	//Y或M没有到达过的KFC的时间花费为0
            	//必须是两人都到达过的KFC才能被计入
                if(maze[i][j]=='@'&&cost[0][i][j]>0&&cost[1][i][j]>0)
                {
                    if(cost[0][i][j]+cost[1][i][j]<ans)
                        ans=cost[0][i][j]+cost[1][i][j];
                }
            }
        cout<<ans<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值