UVa 1586 Molar mass(分子量)

Description

Download as PDF

An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. The molar mass of an organic compound is the mass of one mole of the organic compound. The molar mass of an organic compound can be computed from the standard atomic weights of the elements.

\epsfbox{p3900.eps}

When an organic compound is given as a molecular formula, Dr. CHON wants to find its molar mass. A molecular formula, such as C3H4O3 , identifies each constituent element by its chemical symbol and indicates the number of atoms of each element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular element, this quantity is indicated using a subscript after the chemical symbol.

In this problem, we assume that the molecular formula is represented by only four elements, `C' (Carbon), `H' (Hydrogen), `O' (Oxygen), and `N' (Nitrogen) without parentheses.

The following table shows that the standard atomic weights for `C', `H', `O', and `N'.

Atomic NameCarbonHydrogenOxygenNitrogen
Standard Atomic Weight12.01 g/mol1.008 g/mol16.00 g/mol14.01 g/mol


For example, the molar mass of a molecular formula C6H5OH is 94.108 g/mol which is computed by 6 × (12.01 g/mol) + 6 × (1.008 g/mol) + 1 × (16.00 g/mol).

Given a molecular formula, write a program to compute the molar mass of the formula.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case is given in a single line, which contains a molecular formula as a string. The chemical symbol is given by a capital letter and the length of the string is greater than 0 and less than 80. The quantity number n which is represented after the chemical symbol would be omitted when the number is 1 (2$ \le$n$ \le$99) .

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line should contain the molar mass of the given molecular formula.

Sample Input 

4 
C 
C6H5OH 
NH2CH2COOH 
C12H22O11

Sample Output 

12.010 
94.108 
75.070 
342.296
	
	
 
 
 
 
 
 
 
 
一道比较简单的字符串处理的题,根据题目给定的分子式的特点,只会有C,H,O,N四种,都是单个字符,所以不必考虑复杂化学式的处理,而给定的下标范围又是99以内,不会超过两位数,所以遍历一下字符串,当碰到大写字母时就判断后面两个字符的情况,根据是为一个数字还是两个数字还是没有数字来判断当前原子的个数,很容易累加得到结果。代码如下:
	
	
#include <iostream>
#include <cstring>
#include <iomanip>

using namespace std;

int main()
{
	int word[128];		//用来统计对应原子出现的次数
	char str[111];
	int n,len,i;
	double res;
	cin>>n;
	while(n--)
	{
		memset(word,0,sizeof(word));	//每组循环将数组清空
		cin>>str;
		len=strlen(str);
		for(i=0;i<len;i++)
			if(isupper(str[i]))
				word[str[i]]+=(isdigit(str[i+1])?(isdigit(str[i+2])?((str[i+1]-48)*10+(str[i+2]-48)):str[i+1]-48):1);//通过判断原子后面的字符有几个是数字来决定统计的数量
		res=word['C']*12.01+word['H']*1.008+word['O']*16.0+word['N']*14.01;		//得出结果
		cout<<setiosflags(ios::fixed)<<setprecision(3)<<res<<endl;
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值