UVa 1225 Digit Counting(数字统计)

Description

Download as PDF

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N(1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 , the sequence is:

12345678910111213

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

Input 

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each test case, there is one single line containing the number N .

Output 

For each test case, write sequentially in one line the number of digit 0, 1,...9 separated by a space.

Sample Input 

2 
3 
13

Sample Output 

0 1 1 1 0 0 0 0 0 0 
1 6 2 2 1 1 1 1 1 1
	
	
 
 
 
 
看到这题联想到之前做的数书页的题,只不过这个数据范围比较小,10000以内暴力就可过,不必用到动态规划。基本思路是开一个统计0-9各数字出现次数的全局计数数组cont[10],每组输入的时候将数组清零,写一个函数setCountNumber,把传入的参数不断取末位数并统计进计数数组的对应位,给定一个n,从1循环到n,对于每次循环,将i传入函数中,进行统计,最后循环结束后依次输出计数数组中的值即可。代码如下:
	
	
#include <iostream>
#include <cstring>

using namespace std;

int cont[10];	//统计0-9各数字出现的次数
void setCountNumber(int n);		//将指定整数分割,并统计进数组里

int main()
{

	int i,n,num;
	cin>>n;
	while(n--)
	{
		memset(cont,0,sizeof(cont));	//清空数组
		cin>>num;
		for(i=1;i<=num;i++)
			setCountNumber(i);	//每次循环都将当前数传入函数中处理
		for(i=0;i<=9;i++)
		{
			cout<<cont[i];
			if(i!=9)
				cout<<" ";
			else
				cout<<endl;
		}
	}

	return 0;
}

void setCountNumber(int n)
{
	int r;
	while(n)	//不断取末位,并统计
	{
		r=n%10;
		cont[r]++;
		n/=10;
	}
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值