UVa 253 Cube painting(骰子涂色)

Description

Download as PDF


 Cube painting 

We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube's faces are numbered as in Figure 1.

picture21

Figure 1.

Since a cube has 6 faces, our machine can paint a face-numbered cube in tex2html_wrap_inline126 different ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a br, or g. The tex2html_wrap_inline128 character ( tex2html_wrap_inline130 ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 tex2html_wrap_inline134 , the one changes into the other.

tex2html_wrap138tex2html_wrap140

Input

The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)

Output

The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation as describes above, FALSE otherwise.

Sample Input

rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg

Sample Output

TRUE
FALSE
FALSE
	
	

这题比较简单,就是一个模拟匹配的过程,根据题目给的颜色顺序一一匹配,用一组标记变量记录对应面(正方体有三对面)是否匹配过,依次枚举,匹配数为3的时候即证明两骰子等价(其实逻辑很简单就是想起来比较抽象,我是用一个魔方转过来转过去才想清楚的。。。。),代码如下:

#include <iostream>
#include <cstring>

using namespace std;

int main()
{
	ios::sync_with_stdio(false);
	char c1[15],c2[15];	//存两个骰子各面的颜色
	while(cin>>c1)
	{
		bool mark[3]={0};	//存储对应面是否已经匹配
		int cont=0;	//统计匹配对数
		strcpy(c2,c1+6);	//将字符串分割
		c1[6]=0;
		for(int i=0;i<3;i++)
			for(int j=0;j<3;j++)
				if((!mark[j])&&((c1[i]==c2[j]&&c1[5-i]==c2[5-j])||(c1[i]==c2[5-j]&&c1[5-i]==c2[j])))	//未匹配且题述面对应相等则匹配数累加1
				{
					mark[j]=true;
					cont++;
					break;
				}
		cout<<(cont==3?"TRUE":"FALSE")<<endl;	//如果3对匹配才是完全等价
	}

	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值