SDUT 2121 数据结构实验之链表六:有序链表的建立

数据结构实验之链表六:有序链表的建立

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

输入

第一行输入整数个数N;
第二行输入N个无序的整数。

输出

依次输出有序链表的结点值。

示例输入

6
33 6 22 9 44 5

示例输出

5 6 9 22 33 44

提示

不得使用数组!


#include <bits/stdc++.h>

using namespace std;

struct lists
{
	struct node
	{
		int data;
		struct node *next;
	}*head;

	lists()
	{
		head=(struct node *)malloc(sizeof(struct node));
		head->next=NULL;
	}
	void add(int n)
	{
		struct node *p,*src;
		p=(struct node *)malloc(sizeof(struct node));
		p->data=n;
		p->next=NULL;
		src=head;
		while(src->next&&(src->next->data)<n)
			src=src->next;
		p->next=src->next;
		src->next=p;
	}
	void print()
	{
		struct node *p=head->next;
		while(p)
		{
			if(p!=head->next)
				cout<<" ";
			cout<<p->data;
			p=p->next;
		}
		cout<<endl;
	}
};

int main()
{
	ios::sync_with_stdio(false);
	lists s;
	int n,num;
	cin>>n;
	while(n--)
	{
		cin>>num;
		s.add(num);
	}
	s.print();

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值