Prime Ring Problem HDU - 1016(素数圈和)

Prime Ring Problem HDU - 1016

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include <algorithm>
#include <cstdio>
#include <cmath>
#include <iostream>
#include <string.h>
using namespace std;

int n,a[100005],b[100005];//a数组用来标记数是否用过了 
int is_prime(int x) {//判断素数 
	for(int i=2; i<=sqrt(x); i++)
		if(x%i==0) {
			return 0;
		}
	return 1;
}

void dfs(int step) {
	if(step==n&&is_prime(b[0]+b[n-1])) {//判断首尾之和是否是素数 
		for(int i=0; i<n; i++) {
			cout<<b[i];
			if(i<n-1)//格式要求 
				cout<<" ";
		}
		cout<<endl;
	}
	for(int i=2; i<=n; i++) {
		if(a[i]==0&&is_prime(b[step-1]+i)) { //a[i]==0表示该数没有用过,并判断上一步与该数之和是否为素数 
			b[step]=i;//将i存到b数组中 
			a[i]=1;//标记已经用过 
			dfs(step+1);
			a[i]=0;//一定要将该数赋值为0,在进行下一次递归 
		}
	}
}

int main() {
	int t=1;
	while(cin>>n) {
		cout<<"Case "<<t++<<":"<<endl;
		//	a[100005]= {0};
		memset(a,0,sizeof(a));//将a数组赋值为零 
		b[0]=1;
		dfs(1);
		cout<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值