hduoj 1016 素数环 DFS +筛选法求素数

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66383    Accepted Submission(s): 28451


 

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input

n (0 < n < 20).

 

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

 

Sample Input

 

6 8

 

 

Sample Output

 

Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

 

 

Source

Asia 1996, Shanghai (Mainland China)

 

刚开始用全拍列,超时了,然后自己想了想,DFS应该可以,我心里正想着DFS也应该超时,没想到a了,^_^

312ms,这是我做出来的第一道搜索题。加油,蓝孩!Jeep,加油!加油,为了父母。

再做一遍,居然没做出来,输入如果奇数,则输出No Answer,这点可以加速。

#include<iostream>
using namespace std;
int prim[50]={0};
int n,k=1;
bool c[30];
int b[30];
int df=0;
void dfs(int d,int f)
{
	int i,j;
	if(f-1==n&&!prim[d+b[1]])
	{
		df=1;
		b[f]=d;
		for(i=1;i<=n;i++)
		if(i==1)
		printf("%d",b[i]);
		else
		printf(" %d",b[i]);
		printf("\n");
		return ;
	}
	else
	for(i=1;i<=n;i++)
	{
		if(!c[i]&&!prim[i+b[f-1]])
		{
			c[i]=true;
			b[f]=i;
			dfs(i,f+1);
			c[i]=false;
		}
	}
}
int main()
{
	prim[0]=1;
	prim[1]=1;
	for(int i=2;i<50;i++)
	{
		for(int j=2;j*i<50;j++)
		{
			prim[i*j]=1;
		}
	}
	
	int m;
	while(~scanf("%d",&n),n)
	{
	    printf("Case %d:\n",k++);
		if(n&1&&n!=1)
		{
			printf("No Answer\n");
			continue;
		}
		c[1]=true;
		b[1]=1;
		
		dfs(1,2);
		
		if(!df)
		{
			printf("No Answer\n");
		}
		df=0;
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值