HDU 1116 Play on Words

 

 

 

Problem Description

 

 

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
 

 

Input

 

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
 

 

Output

 

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".
 

 

Sample Input

 

 
3 2 acm ibm 3 acm malform mouse 2 ok ok
 

 

Sample Output

 

 
The door cannot be opened. Ordering is possible. The door cannot be opened.
 

 

这一题运用了并查集和欧拉道路,这段代码简洁高效易懂,希望能帮到大家。

 

现在说一下简单概念与结论,什么是欧拉道路,就是每一条边可以不重复的走一遍就是欧拉道路,如果刚好回到原点,那就是欧拉回路(是特殊情况)。
什么时候可以不重复的走完所有边?
(1)对于无向图来说,就是所有点的度为偶数,或者有且只有两个点的度为奇数其他点为均为偶数
(2)对于有向图来说就是所有点的入度与出度都相等或者存在一个点入度比出度大一存在另一个点出度比入度大一,其他点的入度与出度相等。
 
AC代码:
 
# include<cstdio>
# include<cstring>
# include<vector>
using namespace std;
const int maxn = 1000 + 5;
int pa[256];//并查集
int findset(int x) {//查找父亲即节点
	return pa[x] != x ? pa[x] = findset(pa[x]) : x;
} 
int used[256], deg[256];//是否出现过度数
int main(){
	int T;
	scanf("%d", &T);
	while(T--){
		int n;
		char word[maxn];//临时存单词
		scanf("%d", &n); 
		memset(used, 0, sizeof(used)); //初始化 
		memset(deg, 0, sizeof(deg));
		for(int ch = 'a'; ch <= 'z'; ch++)
		pa[ch] = ch; // 初始化并查集  
		int cc = 26; // 连通块个数   
		for(int i = 0; i < n; i++) {     
			scanf("%s", word);    
			char c1 = word[0], c2 = word[strlen(word)-1];    
			deg[c1]++;    
			deg[c2]--;
			used[c1] = used[c2] = 1;
			int s1 = findset(c1), s2 = findset(c2);
			if(s1 != s2){ 
				pa[s1] = s2; cc--;
			}
		}   
		vector<int> d;
		for(int ch = 'a'; ch <= 'z'; ch++) {
			if(!used[ch])
			cc--; // 没出现过的字母  
			else if(deg[ch] != 0)
			d.push_back(deg[ch]);
		}
		bool ok = false;
		if(cc == 1 && (d.empty() || (d.size() == 2 && (d[0] == 1 || d[0] == -1))))
		ok = true;
		if(ok)
		printf("Ordering is possible.\n");
		else
		printf("The door cannot be opened.\n");
	 }
	return 0;
}

 
 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值