杭电OJ 2734. Quicksum

题目描述:

Problem Description

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

ACM: 1*1 + 2*3 + 3*13 = 46MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

 

Input

The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

 

Output

For each packet, output its Quicksum on a separate line in the output.
 

Sample Input

ACM

MID CENTRAL

REGIONAL PROGRAMMING CONTEST

ACN

A C M

ABC

BBC

#

 

Sample Output

46

650

4690

49

75

14

15

 

思路:

题目很简单。

需要注意的一点是,C++的cin输入,默认将空格和回车作为输入流的终止符。根据题意,我们不能把空格作为终止符,而是要当作正常的字符输入,因此需要用到getline()函数,具体用法见代码。

 

实现(C++):

#include <iostream>
#include <string>
using namespace std;

int main(){
	
	string str;

	while(getline(cin, str)){
		if(str=="#")
			break;
		
		int result=0;
		for(int i=0; i<str.size(); i++){
			if(str[i]==' ')
				continue;
			result+=(i+1)*(str[i]-'A'+1);
		}

		cout<<result<<endl;
	}
	
	return 1;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值