POJ 2312 Battle City

链接:http://poj.org/problem?id=2312


Battle City

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7580 Accepted: 2545

Description


Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now.


What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).


Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input


The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output


For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

Sample Input

3 4
YBEB
EERE
SSTE
0 0


Sample Output

8

Source

POJ Monthly,鲁小石

大意——在坦克大战游戏中,要让自己找到敌人并消灭它。问:给你一个地图,Y表示自己,T表示敌人,E表示空地,B表示砖墙,R表示河流,S表示金属墙,你只能通过E和T,只需一步,B,需两步,因为要先打掉它。并且你只能从四个方向走,即上下左右。求出到达敌人位置的最小步数。如若不能到达,输出-1。

思路——题目要求求出从初始位置到目的位置的最小步数,即最短通路,所以可以使用BFS;又E,T和B所需的步数不同,所以可以使用优先队列,使所需步数少的状态先出队列。
复杂度分析——时间复杂度:O(n*m),空间复杂度:O(n*m)

附上AC代码:


#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
typedef unsigned int UI;
typedef long long LL;
typedef unsigned long long ULL;
typedef long double LD;
const double PI = 3.14159265;
const double E = 2.71828182846;
const short MAX = 305;
const short dir[4][2] = {{-1, 0}, {1, 0}, {0, -1}, {0, 1}};
char map[MAX][MAX];
bool flag[MAX][MAX];
int n, m;
struct node
{
	int x, y;
	int step;
	bool operator < (const node & p) const{
		return step > p.step;
	}
};

int bfs(int x, int y, int z, int v);

int main()
{
	ios::sync_with_stdio(false);
	while (cin >> n >> m && (n!=0 || m!=0))
	{
		for (int i=0; i<n; i++)
			cin >> map[i];
		int ya, yb, ta, tb;
		memset(flag, 0, sizeof(flag));
		for (int i=0; i<n; i++)
			for (int j=0; j<m; j++)
			{
				if (map[i][j] == 'Y')
				{
					ya = i;
					yb = j;
				}
				else if (map[i][j] == 'T')
				{
					ta = i;
					tb = j;
				}
			}
		flag[ya][yb] = 1;
		int ans = bfs(ya, yb, ta, tb);
		cout << ans << endl;
	}
	return 0;
}

int bfs(int x, int y, int z, int v)
{
	priority_queue<node> que;
	node p;
	p.x = x;
	p.y = y;
	p.step = 0;
	que.push(p);
	while (!que.empty())
	{
		p = que.top();
		que.pop();
		x = p.x;
		y = p.y;
		int step = p.step;
		if (x==z && y==v)
			return step;
		node pp;
		for (int i=0; i<4; i++)
		{
			pp.x = x+dir[i][0];
			pp.y = y+dir[i][1];
			pp.step = 0;
			if (pp.x>=0 && pp.x<n && pp.y>=0 && pp.y<m)
			{
				if (map[pp.x][pp.y]=='E' || map[pp.x][pp.y]=='T')
					pp.step = step+1;
				else if (map[pp.x][pp.y]=='B')
					pp.step = step+2;
				if (pp.step>0 && flag[pp.x][pp.y]==0)
				{
					flag[pp.x][pp.y] = 1;
					que.push(pp);
				}
			}
		}
	}
	return -1;
}


内容概要:本文详细介绍了如何利用Simulink进行自动代码生成,在STM32平台上实现带57次谐波抑制功能的霍尔场定向控制(FOC)。首先,文章讲解了所需的软件环境准备,包括MATLAB/Simulink及其硬件支持包的安装。接着,阐述了构建永磁同步电机(PMSM)霍尔FOC控制模型的具体步骤,涵盖电机模型、坐标变换模块(如Clark和Park变换)、PI调节器、SVPWM模块以及用于抑制特定谐波的陷波器的设计。随后,描述了硬件目标配置、代码生成过程中的注意事项,以及生成后的C代码结构。此外,还讨论了霍尔传感器的位置估算、谐波补偿器的实现细节、ADC配置技巧、PWM死区时间和换相逻辑的优化。最后,分享了一些实用的工程集成经验,并推荐了几篇有助于深入了解相关技术和优化控制效果的研究论文。 适合人群:从事电机控制系统开发的技术人员,尤其是那些希望掌握基于Simulink的自动代码生成技术,以提高开发效率和控制精度的专业人士。 使用场景及目标:适用于需要精确控制永磁同步电机的应用场合,特别是在面对高次谐波干扰导致的电流波形失真问题时。通过采用文中提供的解决方案,可以显著改善系统的稳定性和性能,降低噪声水平,提升用户体验。 其他说明:文中不仅提供了详细的理论解释和技术指导,还包括了许多实践经验教训,如霍尔传感器处理、谐波抑制策略的选择、代码生成配置等方面的实际案例。这对于初学者来说是非常宝贵的参考资料。
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值