链接:http://poj.org/problem?id=2312
Battle City
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7580 Accepted: 2545
Description
Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now.
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).
Input
The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
Output
Sample Input
3 4YBEB
EERE
SSTE
0 0
Sample Output
8Source
POJ Monthly,鲁小石
大意——在坦克大战游戏中,要让自己找到敌人并消灭它。问:给你一个地图,Y表示自己,T表示敌人,E表示空地,B表示砖墙,R表示河流,S表示金属墙,你只能通过E和T,只需一步,B,需两步,因为要先打掉它。并且你只能从四个方向走,即上下左右。求出到达敌人位置的最小步数。如若不能到达,输出-1。
思路——题目要求求出从初始位置到目的位置的最小步数,即最短通路,所以可以使用BFS;又E,T和B所需的步数不同,所以可以使用优先队列,使所需步数少的状态先出队列。
复杂度分析——时间复杂度:O(n*m),空间复杂度:O(n*m)
附上AC代码:
#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
typedef unsigned int UI;
typedef long long LL;
typedef unsigned long long ULL;
typedef long double LD;
const double PI = 3.14159265;
const double E = 2.71828182846;
const short MAX = 305;
const short dir[4][2] = {{-1, 0}, {1, 0}, {0, -1}, {0, 1}};
char map[MAX][MAX];
bool flag[MAX][MAX];
int n, m;
struct node
{
int x, y;
int step;
bool operator < (const node & p) const{
return step > p.step;
}
};
int bfs(int x, int y, int z, int v);
int main()
{
ios::sync_with_stdio(false);
while (cin >> n >> m && (n!=0 || m!=0))
{
for (int i=0; i<n; i++)
cin >> map[i];
int ya, yb, ta, tb;
memset(flag, 0, sizeof(flag));
for (int i=0; i<n; i++)
for (int j=0; j<m; j++)
{
if (map[i][j] == 'Y')
{
ya = i;
yb = j;
}
else if (map[i][j] == 'T')
{
ta = i;
tb = j;
}
}
flag[ya][yb] = 1;
int ans = bfs(ya, yb, ta, tb);
cout << ans << endl;
}
return 0;
}
int bfs(int x, int y, int z, int v)
{
priority_queue<node> que;
node p;
p.x = x;
p.y = y;
p.step = 0;
que.push(p);
while (!que.empty())
{
p = que.top();
que.pop();
x = p.x;
y = p.y;
int step = p.step;
if (x==z && y==v)
return step;
node pp;
for (int i=0; i<4; i++)
{
pp.x = x+dir[i][0];
pp.y = y+dir[i][1];
pp.step = 0;
if (pp.x>=0 && pp.x<n && pp.y>=0 && pp.y<m)
{
if (map[pp.x][pp.y]=='E' || map[pp.x][pp.y]=='T')
pp.step = step+1;
else if (map[pp.x][pp.y]=='B')
pp.step = step+2;
if (pp.step>0 && flag[pp.x][pp.y]==0)
{
flag[pp.x][pp.y] = 1;
que.push(pp);
}
}
}
}
return -1;
}