HDU 1097 A hard puzzle

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1097

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34724    Accepted Submission(s): 12469

Problem Description


lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input


There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

Output


For each test case, you should output the a^b's last digit number.

Sample Input


   
   
7 66 8 800

Sample Output


   
   
9 6

Author
eddy

Recommend
JGShining

大意——给你两个数ab,要你求出a^b的最后一位数码。其中0<a,b<=2^30


思路——这显然是一道数论的题目。两个数都很大,直接去求是不可能的。我们可以想到用二分求快速幂,但是数据很大,会溢出,怎么办?那么我们可以边乘边模啊!这样就既不会溢出,也不会超时了。


复杂度分析——时间复杂度:O(log(b)),空间复杂度:O(1)


附上AC代码:


#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <map>
using namespace std;
typedef unsigned int UI;
typedef long long LL;
typedef unsigned long long ULL;
typedef long double LD;
const double pi = acos(-1.0);
const double e = exp(1.0);
const double eps = 1e-8;
const int mod = 10;

int quick_pow(int a, int b);

int main()
{
	ios::sync_with_stdio(false);
	int a, b;
	while (~scanf("%d%d", &a, &b))
	{
		printf("%d\n", quick_pow(a, b));
	}
	return 0;
}

int quick_pow(int a, int b)
{
	int res = 1;
	while (b > 0)
	{
		if (b & 1)
			res = ((res%mod)*(a%mod))%mod;
		a = ((a%mod)*(a%mod))%mod;
		b >>= 1;
	}
	return res;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值