POJ 1163 The Triangle

链接:http://poj.org/problem?id=1163

The Triangle

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 41060 Accepted: 24800

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Source
IOI 1994

大意——给定一个n层的三角形数字塔,从顶到底只能从两个方向向下走,从左或从右,问:从顶到底路径数值和最大的那个数。

思路——显然这是一个最简单的dp问题。我们从顶向下递推即可。边界点(i,0)只有一条路从(i-1,0)过来,则dp[i][0] = dp[i-1][0] + a[i][0];边界点(i,i)也只有一条路从(i-1,i-1)过来,则dp[i][i] = dp[i-1][i-1] + a[i][i];对于非边界点(i,j),它只能从(i-1,j-1)或者(i-1,j)过来,则dp[i][j]=max{dp[i-1][j-1],dp[i-1][j]} +a[i][j]。因此,结果即为max{dp[n-1][j]|j=0,1,...,n-1}。

复杂度分析——时间复杂度:O(n^2),空间复杂度:O(n^2)

附上AC代码:


#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;
typedef unsigned int UI;
typedef long long LL;
typedef unsigned long long ULL;
typedef long double LD;
const double PI = 3.14159265;
const double E = 2.71828182846;
const short MAX = 100;

int max(int a, int b);

int main()
{
	ios::sync_with_stdio(false);
	short num[MAX][MAX];
	int dp[MAX][MAX];
	int N;
	while (cin >> N)
	{
		for (int i=0; i<N; i++)
			for (int j=0; j<=i; j++)
				cin >> num[i][j];
		for (int i=0; i<N; i++)
			for (int j=0; j<=i; j++)
			{
				if (0 == i)
					dp[i][j] = num[i][j];
				else if (0 == j)
					dp[i][j] = dp[i-1][j]+num[i][j];
				else if (i == j)
					dp[i][j] = dp[i-1][j-1]+num[i][j];
				else
					dp[i][j] = max(dp[i-1][j], dp[i-1][j-1])+num[i][j];
			}
		int ans = dp[N-1][0];
		for (int i=1; i<N; i++)
			ans = max(ans, dp[N-1][i]);
		cout << ans << endl;
	}
	return 0;
}

int max(int a, int b)
{
	if (a > b)
		return a;
	return b;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值