题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1548
A strange lift
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20912 Accepted Submission(s): 7646
Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
Sample Input
5 1 5 3 3 1 2 5 0
Sample Output
3
Recommend
8600
思路:简单的BFS。套用BFS的模板即可。详见代码。
附上AC代码:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 205;
struct node{
int pos, step;
bool operator < (const node & p) const {
return step > p.step;
}
};
int f[maxn];
bool vis[maxn];
int n, s, t;
int bfs(){
priority_queue<node> q;
node p;
p.pos = s;
p.step = 0;
q.push(p);
while (!q.empty()){
p = q.top();
q.pop();
int pos=p.pos, step=p.step;
if (pos == t)
return step;
p.pos = pos+f[pos];
p.step = 0;
if (p.pos <= n){
p.step = step+1;
if (!vis[p.pos]){
vis[p.pos] = true;
q.push(p);
}
}
p.pos = pos-f[pos];
p.step = 0;
if (p.pos >= 1){
p.step = step+1;
if (!vis[p.pos]){
vis[p.pos] = true;
q.push(p);
}
}
}
return -1;
}
int main(){
while (~scanf("%d", &n) && n){
scanf("%d%d", &s, &t);
for (int i=1; i<=n; ++i)
scanf("%d", f+i);
memset(vis, false, sizeof(bool)*(n+1));
vis[s] = true;
printf("%d\n", bfs());
}
return 0;
}