杭电 HDU ACM 1548 A strange lift(简单广搜)

C - A strange lift
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input

    
    
5 1 5 3 3 1 2 5 0
 

Sample Output

    
    
3 单纯的广搜发现MLE,那么就肯定有剪枝的地方,模拟一下广搜过程中,是先遍历按一次所能到达的地方,从按一次之后所能到达的所有地方开始遍历再按一次所能到达的地方 那么就可能出现按完两次之后又跑到按完一次就完全可以到达的楼层且并不是优解,此时是没有必要重复往队列中加入结点的,所以可以开一个数组来标记当前楼层是否在 队列中即可,不再则加入。 另外对于判断是否能够到达,试想宽搜深度到达n-1的时候也没有发现终点,那么必然存在循环与某些楼层间,另外当无论怎么走都不可能使某些 楼层加入队列此时 也应该输出-1.
#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF=204;
int cnt[INF];
int inq[INF];
int n,a,b;
struct Node
{
    int floor,num,time;
    Node(int f,int n,int t):floor(f),num(n),time(t){}
    Node(){}
};

Node cur,next;

void bfs()
{
    memset(inq,0,sizeof(inq));
    cur.floor=a;
    cur.num=cnt[a];
    cur.time=0;
    inq[a]=1;
    queue<Node>q;
    q.push(cur);
    while(!q.empty())
    {
        Node u = q.front();
        q.pop();
        int tx=u.floor;
        int ty=u.num;//cout<<tx<<" "<<ty<<" "<<u.num<<endl;
        inq[tx]=0;
        if(tx==b)
        {
            cout<<u.time<<endl;return ;
        }
        if(u.time>n-1)
        {
            cout<<-1<<endl;return ;
        }
        for(int i=0;i<2;i++)
        {
            if(i==0)
            {
                int x=tx+ty;
                if(n>=x&&!inq[x])
               {
                   inq[x]=1;
                    q.push(Node(x,cnt[x],u.time+1));
               }
                //cout<<"u.time="<<u.time<<endl;
            }
            if(i==1)
            {
                int x=tx-ty;
                if(x>=1&&!inq[x])
                   {
                   inq[x]=1;
                    q.push(Node(x,cnt[x],u.time+1));
               }
            }
        }
    }
    cout<<-1<<endl;
}
int main()
{
    while(cin>>n,n)
    {
        cin>>a>>b;
        for(int i=1;i<=n;i++)
            scanf("%d",&cnt[i]);
            bfs();
    }
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值