hdoj 1084 What Is Your Grade?



http://acm.hdu.edu.cn/showproblem.php?pid=1084

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8691    Accepted Submission(s): 2681


Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!
 


Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 


Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 


Sample Input
  
  
4 5 06:30:17 4 07:31:27 4 08:12:12 4 05:23:13 1 5 06:30:17 -1
 


Sample Output
  
  
100 90 90 95 100
要注意红色部分,不是frist,开始看成frist错了好几次
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct Subject
{
    int N;
    int P;
    char TIME[20];
    int score;
}man[200];
int cmp_P_T(const void *a,const void *b)
{
    struct Subject *c=(Subject *)a;
    struct Subject *d=(Subject *)b;
    if(c->P!=d->P)
        return d->P-c->P;
    else
        return strcmp(c->TIME,d->TIME);
}
int cmp_N(const void *a,const void *b)
{
    return ((Subject *)a)->N-((Subject *)b)->N;
}
int main()
{
    int i,j,k,N,a[10],b[10],c[10];
    while(scanf("%d",&N)&&N!=-1)
    {
        for(i=0;i<N;i++)
        {
            scanf("%d %s",&man[i].P,man[i].TIME);
            man[i].N=i;
        }
       // man[i].P=-1;//man[i].P必须和前面的不一样,所以man[i].P=-1
        qsort(man,N,sizeof(man[0]),cmp_P_T);

        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        for(i=0,j=0,a[0]=man[0].P;i<N;i++)//将出现得分的情况放到数组a中,如得分为5,5,5,4,3,3,2.则a数组为5,4,3,2.
        if(man[i].P!=a[j])
        a[++j]=man[i].P;

        for(i=0,j=0;i<N;i++)//将得分出现的次数放到b数组中
        if(man[i].P==a[j])
        b[j]+=1;
        else
        b[++j]+=1;

        for(i=0;i<=j;i++)//得分出现的次数的一般
        if(b[i]>1)
        c[i]=b[i]/2;
        else
        c[i]=b[i];

        //for(i=0;i<=j;i++)
        //printf("%d %d %d#\n",a[i],b[i],c[i]);

        for(i=0,j=0,k=1;i<N;i++)
        {
            if(man[i].P==5)
            man[i].score=100;

            if(man[i].P==4&&k<=c[j])
            man[i].score=95;
            if(man[i].P==4&&k>c[j])
            man[i].score=90;

            if(man[i].P==3&&k<=c[j])
            man[i].score=85;
            if(man[i].P==3&&k>c[j])
            man[i].score=80;

            if(man[i].P==2&&k<=c[j])
            man[i].score=75;
            if(man[i].P==2&&k>c[j])
            man[i].score=70;

            if(man[i].P==1&&k<=c[j])
            man[i].score=65;
            if(man[i].P==1&&k>c[j])
            man[i].score=60;

            if(man[i].P==0)
            man[i].score=50;

            k++;
            if(k>b[j])
            {
                j+=1;
                k=1;
            }
        }

        //for(i=0;i<N;i++)
        //printf("%d %s %d#\n",man[i].P,man[i].TIME,man[i].score);
        qsort(man,N,sizeof(man[0]),cmp_N);
        for(i=0;i<N;i++)
        printf("%d\n",man[i].score);
        printf("\n");


    }
    return 0;
}

以下是对提供的参考资料的总结,按照要求结构化多个要点分条输出: 4G/5G无线网络优化与网规案例分析: NSA站点下终端掉4G问题:部分用户反馈NSA终端频繁掉4G,主要因终端主动发起SCGfail导致。分析显示,在信号较好的环境下,终端可能因节能、过热保护等原因主动释放连接。解决方案建议终端侧进行分析处理,尝试关闭节电开关等。 RSSI算法识别天馈遮挡:通过计算RSSI平均值及差值识别天馈遮挡,差值大于3dB则认定有遮挡。不同设备分组规则不同,如64T和32T。此方法可有效帮助现场人员识别因环境变化引起的网络问题。 5G 160M组网小区CA不生效:某5G站点开启100M+60M CA功能后,测试发现UE无法正常使用CA功能。问题原因在于CA频点集标识配置错误,修正后测试正常。 5G网络优化与策略: CCE映射方式优化:针对诺基亚站点覆盖农村区域,通过优化CCE资源映射方式(交织、非交织),提升RRC连接建立成功率和无线接通率。非交织方式相比交织方式有显著提升。 5G AAU两扇区组网:与三扇区组网相比,AAU两扇区组网在RSRP、SINR、下载速率和上传速率上表现不同,需根据具体场景选择适合的组网方式。 5G语音解决方案:包括沿用4G语音解决方案、EPS Fallback方案和VoNR方案。不同方案适用于不同的5G组网策略,如NSA和SA,并影响语音连续性和网络覆盖。 4G网络优化与资源利用: 4G室分设备利旧:面对4G网络投资压减与资源需求矛盾,提出利旧多维度调优策略,包括资源整合、统筹调配既有资源,以满足新增需求和提质增效。 宏站RRU设备1托N射灯:针对5G深度覆盖需求,研究使用宏站AAU结合1托N射灯方案,快速便捷地开通5G站点,提升深度覆盖能力。 基站与流程管理: 爱立信LTE基站邻区添加流程:未提供具体内容,但通常涉及邻区规划、参数配置、测试验证等步骤,以确保基站间顺畅切换和覆盖连续性。 网络规划与策略: 新高铁跨海大桥覆盖方案试点:虽未提供详细内容,但可推测涉及高铁跨海大桥区域的4G/5G网络覆盖规划,需考虑信号穿透、移动性管理、网络容量等因素。 总结: 提供的参考资料涵盖了4G/5G无线网络优化、网规案例分析、网络优化策略、资源利用、基站管理等多个方面。 通过具体案例分析,展示了无线网络优化中的常见问题及解决方案,如NSA终端掉4G、RSSI识别天馈遮挡、CA不生效等。 强调了5G网络优化与策略的重要性,包括CCE映射方式优化、5G语音解决方案、AAU扇区组网选择等。 提出了4G网络优化与资源利用的策略,如室分设备利旧、宏站RRU设备1托N射灯等。 基站与流程管理方面,提到了爱立信LTE基站邻区添加流程,但未给出具体细节。 新高铁跨海大桥覆盖方案试点展示了特殊场景下的网络规划需求。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值