HDU 2717&&poj 3278 Catch That Cow

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13030    Accepted Submission(s): 4012


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
代码如下:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<iostream>
using namespace std;
int con[200010]; //防止越界,考虑最坏情况2*x 
int n,k;
typedef struct node{
	int x,t;
}N;
queue<N>q;

void start()
{
	while(!q.empty())
		q.pop();
	memset(con,0,sizeof(con));
}

int bfs(int n)
{
	N temp;
	temp.x=n;	temp.t=0;
	con[n]=1;	q.push(temp);
	while(!q.empty())
	{
		temp=q.front();
		q.pop();
		if(temp.x==k)
			return temp.t;
		else
		{
			N m;
			m.x=temp.x+1;	m.t=temp.t+1;
			//不越界且未访问 
			if(!con[m.x] && m.x>=0 && m.x<=100000)
			{
				q.push(m);	con[m.x]=1;
			}
			m.x=temp.x-1;
			if(!con[m.x] && m.x>=0 && m.x<=100000)
			{
				q.push(m);	con[m.x]=1;
			}
			m.x=temp.x*2;
			if(!con[m.x] && m.x>=0 && m.x<=100000)
			{
				q.push(m);	con[m.x]=1;
			}
		}
	}
	
}
int main()
{
	while(~scanf("%d%d",&n,&k))
	{
		start();
		printf("%d\n",bfs(n));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值