hdu 4465 Candy

Candy

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 6   Accepted Submission(s) : 5
Special Judge
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?

Input

There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 10 5) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.

Output

For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10 -4 would be accepted.

Sample Input

10 0.400000
100 0.500000
124 0.432650
325 0.325100
532 0.487520
2276 0.720000

Sample Output

Case 1: 3.528175
Case 2: 10.326044
Case 3: 28.861945
Case 4: 167.965476
Case 5: 32.601816
Case 6: 1390.500000

分析:

这个题目是真的难,涉及的知识点很多,首先组合数求概率,在数学上是能够实现的,但是2e5计算机是无法胜任的,这里可以经由log转换一下,详细思路见代码。

代码如下 :


#include <iostream>
#include <string.h>
#include <cstdio>
#include <cmath>
using namespace std;
int n;
double p,inde[400005];

void init(){    //阶乘打表,底数相乘除,即指数相加减
    inde[0]=0;
    for(int i=1;i<=400000;i++)
        inde[i]=inde[i-1]+log(i);
}

double v1(int i)//最后打开的是第一个盒子
{
    double tem=inde[2*n-i]-inde[n]-inde[n-i]+(n+1)*log(p)+(n-i)*log(1-p);
    return tem;
}
double v2(int i)//最后打开的是第二个盒子
{
    double tem=inde[2*n-i]-inde[n]-inde[n-i]+(n+1)*log(1-p)+(n-i)*log(p);
    return tem;
}
int main()
{
    int cnt=0;
    double ans;
    init();
    while(~scanf("%d%lf",&n,&p))
    {
        ans=0;
        for(int i=1;i<=n;i++)
        {
            ans+=i*(exp(v1(i))+exp(v2(i)));//1~n次期望和,概率乘以结果
        }
        printf("Case %d: %lf\n",++cnt,ans);
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值