hdu 5120 Intersection (容斥原理+圆的相交面积模板)

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 3674    Accepted Submission(s): 1388


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
  
  
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
  
  
Case #1: 15.707963 Case #2: 2.250778


分析: 面积=AB大圆相交的面积 - A大圆B小圆相交面积 -  A小圆B大圆相交的面积 + AB小圆相交的面积   (容斥原理)

附:圆的相交求截图


代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define PI acos(-1)
using namespace std;

struct Node {
    double x,y;
}a,b;

double dis(Node a,Node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

double GetArea(double r1,double r2)
{
    double x=dis(a,b);
    double y=r1;
    double z=r2;
    if(x>=(y+z))    return 0.0;
    if(x<fabs(y-z))
    {
        double r=min(r1,r2);
        return PI*r*r;
    }
    double cta1 = acos((x*x+y*y-z*z)/2.0/(x*y));    //利用余弦定理,求出其中一个圆心角的一半
    double cta2 = acos((x*x+z*z-y*y)/2.0/(x*z));    //求出另一个圆心角的一半
    //弧度 cat*r^2/2是扇形的面积,这里正好需要乘2再减去三角形的面积(三角形的面积=1/2*r^2*sin2α,这里用二倍角公式)
    double s1 = r1*r1*cta1-r1*r1*sin(cta1)*(x*x+y*y-z*z)/2/(x*y);
    double s2 = r2*r2*cta2-r2*r2*sin(cta2)*(x*x+z*z-y*y)/2/(x*z);
    return s1+s2;
}

int main()
{
    int t;
    int inde=0;
    scanf("%d",&t);
    while(t--)
    {
        double r1,r2;
        scanf("%lf%lf",&r1,&r2);
        scanf("%lf%lf",&a.x,&a.y);
        scanf("%lf%lf",&b.x,&b.y);
        printf("Case #%d: ",++inde);
        if(a.x==b.x && a.y==b.y)
            printf("%.6lf\n",PI*(r2*r2-r1*r1));
        else
        {
            double ans=0;
            ans+=GetArea(r2,r2);
            ans-=GetArea(r1,r2);
            ans-=GetArea(r2,r1);
            ans+=GetArea(r1,r1);
            printf("%.6lf\n",ans);
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值