2012 Asia Chengdu Regional Contest hdu 4474(数位bfs)

Yet Another Multiple Problem

Time Limit: 40000/20000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 6291    Accepted Submission(s): 1460


Problem Description
There are tons of problems about integer multiples. Despite the fact that the topic is not original, the content is highly challenging. That’s why we call it “Yet Another Multiple Problem”.
In this problem, you’re asked to solve the following question: Given a positive integer n and m decimal digits, what is the minimal positive multiple of n whose decimal notation does not contain any of the given digits?
 

Input
There are several test cases.
For each test case, there are two lines. The first line contains two integers n and m (1 ≤ n ≤ 10 4). The second line contains m decimal digits separated by spaces.
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) while Y is the minimal multiple satisfying the above-mentioned conditions or “-1” (without quotation marks) in case there does not exist such a multiple.
 

Sample Input
  
  
2345 3 7 8 9 100 1 0
 

Sample Output
  
  
Case 1: 2345 Case 2: -1
 

Source
 

分析:听说这是数位bfs,之前也没做过,感觉很微妙,不用记录整个数,每次记录取余后的,即可,详细见代码;

代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <string>
#define N 10005
using namespace std;
bool del[10],vis[N]; //vis标记余数,再次出现只记录第一次,第一次出现的最小
int n,pre[N];//记录前缀数组
char text[N];//记录输出

void Print()    //因为是记录前缀,所以逆置后输出;
{
    string ans;
    int p=0;
    while(p!=0 || ans.empty())
    {
        ans+=text[p];
        p=pre[p];
    }
    reverse(ans.begin(),ans.end());
    cout<<ans<<endl;
}

bool bfs()
{
    queue <int> q;
    int cur;
    q.push(0);
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        for(int i=0;i<10;i++)
        {
            if(del[i] || (cur==0 && i==0))
                continue;
            int yu=(cur*10+i)%n;
            if(vis[yu])
                continue;
            text[yu]='0'+i;
            vis[yu]=1;
            pre[yu]=cur;
            q.push(yu);
            if(yu==0)
                return 1;
        }
    }
    return 0;
}
int main()
{
    int m,cnt=0;
    while(~scanf("%d%d",&n,&m))
    {
        memset(vis,0,sizeof(vis));
        memset(del,0,sizeof(del));
        while(m--)
        {
            int k;
            scanf("%d",&k);
            del[k]=1;
        }
        printf("Case %d: ",++cnt);
        if(!bfs())
            printf("-1\n");
        else
            Print();
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值