杭电第一次多校赛_1001_Add_More_Zero_2017_7_25

1001_Add_More_Zero

题目:

Problem Description
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2^m-1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10^k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

Input
The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1≤m≤10^5.

Output
For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input
1
64

Sample Output
Case #1: 0
Case #2: 19

这道题目的意思是:给出一个m,计算2^m-1有多少位数,m的取值范围是1~10^5.按常规方法计算肯定数值溢出,不管是double还是long long。因为这个数是指数级形式增长的,2的100000次方是一个天文数字。所以,不能直接计算。

我的做法是对其取对数。公式 2^m >= 10^k ==>> k = log10 (2^m) == >> k=m * log10 (2)
这个k就是原来2^m的位数。

代码如下:

#include<iostream>
#include<cmath>

using namespace std;
/*
*用公式k=log10 (2) * m  就可以求出,其中m是2的指数,k是要求的位数
*/
int main()
{
    int  m = 0;
    int kase = 0;
    double s = log10(2);
    while (cin >> m && m) {
        double sum = m* s;
        cout << "Case #" << ++kase << ": " << (int)sum << endl;
    }
    return 0;
}

这是道水题,开赛2分钟就有人AC了,而那时候我才刚登录进去。。。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值