2017杭电多校联赛-Add More Zero 数学找公式

Add More Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2245    Accepted Submission(s): 1053


Problem Description
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between  0  and  (2m1)  (inclusive).

As a young man born with ten fingers, he loves the powers of  10  so much, which results in his eccentricity that he always ranges integers he would like to use from 1  to  10k  (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer  m , your task is to determine maximum possible integer  k  that is suitable for the specific supercomputer.
 

Input
The input contains multiple test cases. Each test case in one line contains only one positive integer  m , satisfying  1m105 .
 

Output
For each test case, output " Case # x y " in one line (without quotes), where  x  indicates the case number starting from  1  and  y  denotes the answer of corresponding case.
 

Sample Input
  
  
1 64
 

Sample Output
  
  
Case #1: 0 Case #2: 19

题目大意:给你m,m满足有2^m-1>=10^k,询问最大k值为多少。

解题思路:有题,我们只需要求得最大k值,则可以列出下列公式:

因此代码就非常好写了。

#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
	int m, k;
	int cas = 0;
	while(~scanf("%d", &m))
	{
         k = log10(2)*m;
		printf("Case #%d: %d\n", ++cas, k);
	}
	return 0;
}

题目链接:点击打开链接http://acm.hdu.edu.cn/contests/contest_showproblem.php?pid=1001&cid=759



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值