ACboy(队列和栈的基础操作)

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
Output
For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT
Sample Output
1
2
2
1
1
2
None
2
3

题目考察队列和栈的使用;栈先进先出,堆先进后出;

首先看看数组模拟栈和堆;

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>

using namespace std;

int q[10000000];
int head, tail;
int main(){

    int T;
    cin >> T;
    while(T--){
        int N;
        string s;
        cin >> N >> s;
        head=tail=0;
        if(s[2]=='F'){                            //栈;
            int x;
            string op;
            while(N--){
            cin >> op;
            if(op[0]=='I'){
                cin >> x;
                q[++tail]=x;
            }
            else{
                if(head>=tail) cout << "None" << endl;
                else cout << q[++head] << endl;
            }
            }
        }
        else{                                            //堆;
            int x;
            string op;
            while(N--){
            cin >> op;
            if(op[0]=='I'){
                cin >> x;
                q[tail++]=x;
            }
            else{
                if(tail<=0) cout << "None" << endl;
                else cout << q[--tail] << endl;
            }
            }
        }
    }

    return 0;
}
使用STL中的栈和堆操作;

头文件分别是#include <queue>(栈)      #include <stack>(堆);

栈和堆的基本操作

#include <stack>

push(x) x加入栈中,即入栈操作

pop() 出栈操作(删除栈顶),只是出栈,没有返回值

top() 返回第一个元素(栈顶元素)

size() 返回栈中的元素个数

empty() 当栈为空时,返回 true


   #include <queue>

push(x) x压入队列的末端

pop() 弹出队列的第一个元素(队顶元素),注意此函数并不返回任何值

front() 返回第一个元素(队顶元素)

back() 返回最后被压入的元素(队尾元素)

empty() 当队列为空时,返回true

size() 返回队列的长度


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <stack>

using namespace std;

int head, tail;

int main(){

    int T;
    cin >> T;
    while(T--){
        int N;
        string s;
        cin >> N >> s;
        if(s[2]=='L'){                            堆;
            int x;
            stack<int> stk;
            string op;
            while(N--){
            cin >> op;
            if(op[0]=='I'){
                cin >> x;
                stk.push(x);
            }
            else{
                if(!stk.empty()){
                    cout << stk.top() << endl;
                    stk.pop();
                }
                else cout << "None" << endl;
            }
            }
        }
        else{                              //栈;
            int x;
            queue<int> q;
            string op;
            while(N--){
            cin >> op;
            if(op[0]=='I'){
                cin >> x;
                q.push(x);
            }
            else{
                if(!q.empty()){
                    cout << q.front() << endl;
                    q.pop();
                }
                else cout << "None" << endl;

            }
            }
        }
    }

    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值