HDU - 1702 ACboy needs your help again!

ACboy needs your help again!

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

ACboy was kidnapped(绑架)!! 
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(. 
As a smart ACMer, you want to get ACboy out of the monster's(怪兽) labyrinth(迷宫).But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy." 
The problems of the monster is shown on the wall: 
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out"). 
and the following N lines, each line is "IN M" or "OUT", (M represent a integer). 
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.(多个测试样例)
The first line has one integer,represent the number oftest cases.(每个样例的第一行是一个整数,代表该样例中的测试数据个数)
And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.对每一个OUT,你都要输出一个相应的整数,如果没有整数可输出,则输出None

Sample Input

4 
4 FIFO 
IN 1 
IN 2 
OUT 
OUT 
4 FILO 
IN 1 
IN 2 
OUT 
OUT 
5 FIFO 
IN 1 
IN 2 
OUT 
OUT 
OUT 
5 FILO 
IN 1 
IN 2 
OUT 
IN 3 
OUT

Sample Output

1 
2 
2 
1 
1 
2 
None 
2 
3

这道题题意很容易读懂,但由于是第一次接触到栈和队列的概念,难免会手足无措。当学会了相关的知识后,解决这道题还是So easy的!栈是先进后出(像一个没有盖子的容器,最先放的往往在最下面,所以最后取出),而队列则是先进先出(类似于排队走过一个山洞,第一个进的肯定是第一个出来)

#include<cstdio>  
#include<cstring>  
#include<stack>//栈的头文件 
#include<queue>//队列的头文件 
using namespace std;
void sta(int m){ 
    stack<int> S;//栈型变量的定义 
    char s[10];
    int a;
    while(m--){
        scanf("%s",s);  
        if(!strcmp(s,"IN")){//字符串不能用逻辑运算符比较大小 
            scanf("%d",&a);  
            S.push(a);//向栈S内输入变量a的值 
        }
        else{
            if(!S.empty()){//S.empty()表示栈变量S为空 
                printf("%d\n",S.top());//如果不为空,则输出最顶端的数 
                S.pop();// 弹出栈的顶端元素 
            }  
            else
                printf("None\n");
        }  
    }  
}
void que(int m){
    queue<int> Q;//队列型变量的定义 
    char s[10];  
    int a;
    while(m--){
        scanf("%s",s);  
        if(!strcmp(s,"IN")){
            scanf("%d",&a);  
            Q.push(a);  
        }  
        else{
            if(!Q.empty()){
                printf("%d\n",Q.front()); //Q.front()代表队列的第一个元素 
                Q.pop();//弹出队列的第一个元素  
            }    
            else      
            	printf("None\n");
        }  
    }  
}
int main(){
    int n;  
    while(~scanf("%d",&n)){
        while(n--){
            int m;  
            char str[10];  
            scanf("%d%s",&m,str);  
            if(!strcmp(str,"FIFO"))  
                que(m);  
            else   
                sta(m);  
        }  
    }
    return 0;  
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值