hdu 1007 quoit design(分冶求距离最近的两点)

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 55334    Accepted Submission(s): 14592


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places.
 

Sample Input
  
  
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
  
  
0.71 0.00 0.75

分冶!!!又是个新算法...

通常的思路是所有点之间的距离都算出来,求最小值;n的阶乘,复杂度大约是O(n^2);5秒,然后我就被T了...

现在讲讲分冶:我也讲不清楚,简单来说就是复杂问题简单化,将问题不断分割分割再分割...有递归的思想在里面;

详情请戳下面链接,讲的很好:

点击打开链接

那么,这道题怎么用分冶写呢?

现在有n个点,把他们按照x轴坐标有小到大排序,然后找到重点mid,分为两部分,分别求这两部分的最短距离,分别记为d1,d2,令d为最小值,找出x轴坐标在mid.x±d范围内的点,按y由小到大排序;然后再找...

还有不明之处可以戳这里点击打开链接

好, 现在看看这道题的代码:

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>

using namespace std;

struct node{
    double x, y;
}point[100005], py[100005];

double get_dis(node a, node b){            //求两点之间距离;
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

bool cmpX(node a, node b){
    return a.x < b.x;
}
bool cmpY(node a, node b){
    return a.y < b.y;
}

double closest(int s, int e){
    if(s==e) return 0;
    if(s+1==e) return get_dis(point[s], point[e]);
    if(s+2==e) return min(get_dis(point[s], point[s+1]), min(get_dis(point[s+1], point[e]),get_dis(point[s], point[e])));
    int mid=(s+e)>>1;
    double ans=min(closest(s, mid), closest(mid, e));
    int cnt=0, i, j;
    for(i=s; i<=e; i++){                    //取出point[mid].x±ans范围内的点;
        if(point[i].x<=point[mid].x+ans && point[i].x>=point[mid].x-ans)
            py[++cnt]=point[i];
    }
    sort(py+1, py+cnt+1, cmpY);
    for(int i=1; i<=cnt; i++){
        for(int j=i+1; j<=cnt; j++){
            if(py[j].y-py[i].y>=ans)
                break;
            ans=min(ans, get_dis(py[i], py[j]));
        }
    }
    return ans;
}
int main(){

    int N;
    while(cin >> N, N){
        for(int i=1; i<=N; i++)
            cin >> point[i].x >> point[i].y;
        sort(point+1, point+N+1, cmpX);
        double dis=closest(1, N);
        printf("%.2f\n", dis/2);
    }

    return 0;
}
hdu上用G++提交被T了,但是C++过了...






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值