PTA 1027 Colors in Mars(读懂题目意思很重要!!)

题目描述如下:

1027 Colors in Mars (20 point(s))

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

遇到的问题与解决思路:

 这里的输出格式一定是#打头的,就是按照样例来,它补充说明的“如果有一个颜色是0,那么在它的左边输出0”,比如输入0 0 0,是输出#0 0 0还是#000000又或者是0?

问题就出在这里!

因为你根本没有理解题目在说什么!!!

题目的意思,如果输出的是1 1 1,那么输出的应该是#010101,用0来补位。

所以,根本不是英文的表述问题,这很清晰,而是自己太急,没冷静下来!

具体解决如下:

#include <cstdio>
const char marsnum[13] = {'0', '1', '2', '3', '4', '5', '6',
 '7', '8', '9' , 'A', 'B', 'C'};
int main()
{
    int deci[3] = {0};
    int mars[6] = {0};
    for (int i = 0; i < 3; i++) {
        scanf("%d", &deci[i]);
    }
    int index = 0;
    for (int i = 0; i < 3; i++) {
        mars[index + 1] = deci[i] % 13;
        mars[index] = deci[i] / 13;
        index += 2;
    }
    /*
    for (int i = 0; i < 6; i++) {
        printf("%d", mars[i]);
    }
    printf("\n");
    */
    printf("#");
        for (int i = 0; i < 6; i++) {
            printf("%c", marsnum[mars[i]]);
        }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值