Colors in Mars(注意输入为0的情况)

该博客主要介绍了如何处理火星上的颜色编码问题,其中颜色以十进制表示,需要转换为使用十六进制替代数制(0-9和A-C)的六位数火星RGB值。提供的C++代码示例展示了如何实现这一转换,确保每个颜色分量至少两位,并以#开头输出最终的火星RGB值。输入和输出格式以及特殊情况(如输入为0时的处理)也在文章中进行了详细说明。
摘要由CSDN通过智能技术生成

Colors in Mars

题目

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

答案

#include<iostream>
#include<vector>
using namespace std;
int main()
{
	vector<int> vec;
	int a[3];
	string ans[3];
	fill(ans,ans+3,"");
	for(int i=0;i<3;i++)
	cin>>a[i];
	for(int i=0;i<3;i++)
	{
		if(a[i]==0)
		{
			ans[i]="00";
			continue;
		}
		while(a[i]!=0)
		{
			vec.push_back(a[i]%13);
			a[i]/=13;
		}
		if(vec.size()==1) ans[i]+='0';
		for(int j=vec.size()-1;j>=0;j--)
		{
			if(vec[j]>=10&&vec[j]<=12) ans[i]+='A'+vec[j]-10;
			else ans[i]+=vec[j]+'0';
		}
		vec.clear();
	}
	cout<<"#";
	for(int i=0;i<3;i++)
	cout<<ans[i];
} 

注意

如果输入为0,直接输出00

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值