POJ 2251 ——Dungeon Master

题目:http://poj.org/problem?id=2251

/**** 广度搜索 ******
**       队列实现        **
**       注意访问标记  **/

     题目大意最短时间内逃出牢笼

Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13024 Accepted: 5044

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!
#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>

using namespace std;

class point
{
public:
    int l , r , c ;
};
int l , r , c ;

char dungeon[50][50][50];
int visit[50][50][50];
int b_l , b_r , b_c , e_l , e_r , e_c ;

void bfs()
{
    int direct[6][3] = {{0,0,1},{0,0,-1},{0,1,0},{0,-1,0},{1,0,0},{-1,0,0}};
    queue<point> Q ;
    point push , temp ;
    visit[b_l][b_r][b_c] = 0;
    push.l = b_l ;
    push.r = b_r ;
    push.c = b_c ;
    Q.push(push) ;

    while(!Q.empty())
    {
        temp = Q.front();
        if(temp.l == e_l && temp.r == e_r && temp.c == e_c)
            return ;

        for(int i = 0; i < 6; i ++)
        {
            push.l = temp.l + direct[i][0] ;
            push.r = temp.r + direct[i][1] ;
            push.c = temp.c + direct[i][2] ;

            if(dungeon[push.l][push.r][push.c] == '.' && visit[push.l][push.r][push.c] == -1)
            {
                visit[push.l][push.r][push.c] = visit[temp.l][temp.r][temp.c] + 1;
                Q.push(push) ;
            }
        }
        Q.pop();
    }
}

int main()
{
    freopen("in.txt","r",stdin);
    int  i , j , k ;
    while(1)
    {
        cin>>l>>r>>c;
        if(!l && !r && !c)
            break ;

        memset(dungeon,'#',sizeof(dungeon));
        memset(visit,-1,sizeof(visit));

        for(i = 1; i <= l; i++)
            for(j = 1; j <= r; j++)
                for(k = 1; k <= c; k++)
                {
                    cin>>dungeon[i][j][k];

                    if(dungeon[i][j][k] == 'S')
                    {
                        b_l = i ;
                        b_r = j ;
                        b_c = k ;
                    }
                    if(dungeon[i][j][k] == 'E')
                    {
                        e_l = i ;
                        e_r = j ;
                        e_c = k ;
                        dungeon[i][j][k] = '.' ;
                    }
                }
        bfs();
        if(visit[e_l][e_r][e_c] != -1)
            cout<<"Escaped in "<<visit[e_l][e_r][e_c]<<" minute(s)."<<endl;
        else
            cout<<"Trapped!"<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值