L2-011. 玩转二叉树

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2

思路:先建树,其实镜像反转就是在层次遍历的时候先遍历右子树,在遍历左子树。

#include <iostream>
#include <string>
#include <cstring>
#include <vector>
#include <set>
#include <map>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>

using namespace std;
const int maxn=1010;
int in_order[maxn];
int per_order[maxn];
int lch[maxn],rch[maxn];
int n;
int Build(int l1,int r1,int l2,int r2)
{
    if(l1>r1) return 0;
    int root=per_order[l1];
    int p=l2;
    while(in_order[p]!=root) p++;
    int cnt=p-l2;
    lch[root]=Build(l1+1,l1+cnt,l2,l2+cnt);
    rch[root]=Build(l1+cnt+1,r1,l2+cnt+1,r2);
    return root;
}
vector<int> ans;
void bfs(int x)
{
    queue<int> p;
    p.push(x);
    ans.push_back(x);
    while(!p.empty())
    {
        int u=p.front();
        p.pop();
        if(rch[u])
        {
            p.push(rch[u]);
            ans.push_back(rch[u]);
        }
        if(lch[u])
        {
            p.push(lch[u]);
            ans.push_back(lch[u]);
        }
    }
}
int main()
{
    cin>>n;
    for(int i=0; i<n; i++)
        cin>>in_order[i];
    for(int i=0; i<n; i++)
        cin>>per_order[i];
    Build(0,n-1,0,n-1);
    bfs(per_order[0]);
    for(int i=0; i<ans.size(); i++)
    {
        if(i==0) cout<<ans[i];
        else cout<<" "<<ans[i];
    }
    cout<<endl;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值