POJ 3250 - Bad hair day(单调栈)

Bad Hair Day
Time Limit: 2000MS
Memory Limit: 65536K
Total Submissions: 17357
Accepted: 5847
Description
Some of FarmerJohn’s N cows (1≤ N ≤ 80,000) are having abad hair day! Since each cow is self-conscious about her messyhairstyle, FJ wants to count the number of other cows that can seethe top of other cows’ heads.
Each cow i has aspecifiedheight hi (1≤ hi ≤1,000,000,000) and is standing in a line of cows all facing east(to the right in our diagrams). Therefore,cow i can see the tops ofthe heads of cows in front of her (namelycows i+1, i+2, andso on), for as long as these cows are strictly shorter thancow i.
Consider this example:
=

= =

= - = Cows facing right –>

= = =

= - = = =

= = = = = =

1 2 3 4 5 6
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow’s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow’s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!
Let ci denotethe number of cows whose hairstyle is visible fromcow i; please compute the sumof c1 through cN.Forthis example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.
Input
Line 1: The number ofcows, N.
Lines 2..N+1: Line i+1 contains a singleinteger that is the height of cow i.
Output
Line 1: A single integer that is thesumof c1 through cN.
Sample Input
6
10
3
7
4
12
2
Sample Output
5

单调栈思路:
题意就是高的向右能够看到身高比他矮的cow的头,求每一个cow能看到的人头数的和。

问题转化就是每个人的头能被看几次的和。

如果用暴力的解法,复杂度是O(N^2)。这里用到了单调栈的数据结构,可以在线性时间里解决这个问题。

具体实现就是维护一个栈,首先先读入一个cow的高度,如果栈顶的cow的高度小于等于读入的这个cow,那么就出栈,直到栈顶的cow的高度大于它,或者栈为空。此时这个栈里的元素都能够看到读入的cow的头顶,即栈的大小就是当前读入的这个cow被看到的次数。

重复操作,直到cow读完。其复杂度是O(N)。

AC代码

#include<stdio.h>
using namespace std;
#define maxn 80005
int qdu[maxn];
int top;
int main()
{
    int n;
    scanf("%d",&n);
    long long ans = 0;
    while(n--)
    {
        int num;
        scanf("%d",&num);
        while(top > 0 && num >= qdu[top-1])   top--;
        ans += top;
        qdu[top++] = num;
    }
    printf("%lld\n",ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值