POJ 3111 - K Best(0/1分数规划)

K Best
Time Limit: 8000MS Memory Limit: 65536K
Total Submissions: 8707 Accepted: 2249
Case Time Limit: 2000MS Special Judge
Description

Demy has n jewels. Each of her jewels has some value vi and weight wi.

Since her husband John got broke after recent financial crises, Demy has decided to sell some jewels. She has decided that she would keep k best jewels for herself. She decided to keep such jewels that their specific value is as large as possible. That is, denote the specific value of some set of jewels S = {i1, i2, …, ik} as

.

Demy would like to select such k jewels that their specific value is maximal possible. Help her to do so.

Input

The first line of the input file contains n — the number of jewels Demy got, and k — the number of jewels she would like to keep (1 ≤ k ≤ n ≤ 100 000).

The following n lines contain two integer numbers each — vi and wi (0 ≤ vi ≤ 106, 1 ≤ wi ≤ 106, both the sum of all vi and the sum of all wi do not exceed 107).

Output

Output k numbers — the numbers of jewels Demy must keep. If there are several solutions, output any one.

Sample Input

3 2
1 1
1 2
1 3
Sample Output

1 2

题意:
给出一些东西他们的价值和重量,让你拿出k个物品,使得他们的价值之和除以重量之和最大.

解题思路:
刚开始想的是对单位价值进行排序,然后把前k个最大的相加,但是发现这样做是错的.
反例数据:2 2
5 3
2 1
k = 2
正确的思想应该是对结果进行二分.
首先是对公式进行变形. sigmaV/sigmaW = R.
那么sigmaV - sigmaW*R >= 0.
即sigma(V-W*R) >= 0.
Ps.如果这个式子的值大于等于0,说明这个R使得条件成立,然后继续去找更大的.

AC代码

#include<stdio.h>
#include<algorithm>
using namespace std;
const int maxn = 100005;
int v[maxn];
int w[maxn];
int ans[maxn];
int n;
int k;

struct node
{
    double t;
    int post;
    bool operator < (const node& b)const
    {
        return t > b.t;
    }
}y[maxn];
bool cmp(double x)
{
    for(int i = 0;i < n;i++)
    {
        y[i].t = v[i] - x*w[i];
        y[i].post = i;
    }
    sort(y,y+n);
    double sum = 0;
    for(int i = 0;i < k;i++)
    {
        sum += y[i].t;
        ans[i] = y[i].post;
    }
    return sum>=0;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        for(int i = 0;i < n;i++)    scanf("%d%d",&v[i],&w[i]);
        double left = 0;
        double right = 0xffffff;
        while(right - left > 1e-7)
        {
            double mid = (left+right)/2;
            if(cmp(mid))    left = mid;
            else            right = mid;
        }
        for(int i = 0;i < k;i++)
            if(!i)  printf("%d",ans[i]+1);
            else    printf(" %d",ans[i]+1);
        putchar('\n');
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值