17 - 01 - 05 POJ 1979 (简单DFS)

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 32704 Accepted: 17802

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

#include<stdio.h>
#include<string.h>
#include<iostream>
#define MAX 30
char map[MAX][MAX];
int tiles = 0;
int height,width;
void DFS(int p,int q);
int main() {
	int i,j,x1,y1;
	while(scanf("%d %d",&width,&height) &&width&&height) {
//		getchar();
		tiles = 0;
		memset(map,0,sizeof(map));  //×¢ÒâÊÇ0£¡
		for(i = 0 ; i < height ; i++ ) {
			for( j = 0; j < width ; j++) {
				scanf("\n%c",&map[i][j]);
				if(map[i][j] == '@') {
					x1 = i;
					y1 = j;
					map[i][j] = '.';
				}
			}
		}
		DFS(x1,y1);
		printf("%d\n",tiles);

	}
	return 0;
}

void DFS(int p,int q)
{

	if(p>=0&&p<height&&q>=0&&q<width&&map[p][q]=='.')
	{
		map[p][q] = '#';
		tiles++;
	}else
		return;
	DFS(p-1,q);
	DFS(p,q-1);
	DFS(p,q+1);
	DFS(p+1,q);
}



//这个题 我在
scanf("\n%c",&map[i][j]);
这句话上栽了大。

我写的scanf没有 \n 无论怎么都是WA。

因为:
scanf是一个匹配模式的函数咯,例如:scanf("%d and %d",&a,&b);那我们输入的格式就是:1 and 2。那scanf("\n");就要匹配换行符啦

---------------------引用自http://bbs.csdn.net/topics/390144086  五楼,感谢。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值