ACM--DFS--poj 1562--Oil Deposits

 

poj地址:http://poj.org/problem?id=1562


                                                        Oil Deposits

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.


Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2


==============================天生骄傲的分割线==============================


描述:

       给出一个N*M的矩形区域和每个区域的状态 – @有/*没有石油,(定义)如果两个有石油的区域是相邻的(水平、垂直、斜)则认为这是属于同一个油田。求这块矩形区域一共有多少油田

输入:

       多组输入,每组输入包括两个整数n,m表示矩阵区域的列数和行数(1<=m,n<=100)和矩阵区域的状态,以

 n=m=-1结束输入


这个题是一个简单的DFS,没什么好说的


<pre name="code" class="cpp">#include<iostream>
#include<stdio.h>
#include<memory.h>
using namespace std;
char map[101][101];
int result;
int n,m;
int move[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
//深度搜索
void dfs(int x,int y){
    int a,b;
    map[x][y] = '*'; //访问过的都由@改为*,剪枝
    for(int i=0;i<8;i++){
       a=x+move[i][0];
       b=y+move[i][1];
       if(a>=0&&a<n&&b>=0&&b<m&&map[a][b]=='@'){
           dfs(a,b);
       }
    }
}
int main(){
   while(cin>>n>>m&&n||m){
        int i,j;
        //初始化
        result=0;
        for(i=0;i<n;i++){
          cin>>map[i];
        }
        for(i=0;i<n;i++){
            for(j=0;j<m;j++){
                if(map[i][j]=='@'){
                    dfs(i,j);
                    result++;
                }

            }
        }
        //打印结果
        printf("%d\n",result);

   }
   return 0;
}


 



参考博客:http://blog.csdn.net/v5zsq/article/details/46591883

                  http://blog.csdn.net/keshacookie/article/details/22817433

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值