LightOJ1074 Extended Traffic【SPFA+DFS 标记负环的结点】

106 篇文章 3 订阅

Extended Traffic

Dhaka city is getting crowded and noisy day by day. Certain roads always remain blocked in congestion. In order to convince people avoid shortest routes, and hence the crowded roads, to reach destination, the city authority has made a new plan. Each junction of the city is marked with a positive integer (≤ 20) denoting the busyness of the junction. Whenever someone goes from one junction (the source junction) to another (the destination junction), the city authority gets the amount (busyness of destination - busyness of source)3 (that means the cube of the difference) from the traveler. The authority has appointed you to find out the minimum total amount that can be earned when someone intelligent goes from a certain junction (the zero point) to several others.

Input

Input starts with an integer T (≤ 50), denoting the number of test cases.

Each case contains a blank line and an integer n (1 < n ≤ 200) denoting the number of junctions. The next line contains nintegers denoting the busyness of the junctions from 1 to n respectively. The next line contains an integer m, the number of roads in the city. Each of the next m lines (one for each road) contains two junction-numbers (source, destination) that the corresponding road connects (all roads are unidirectional). The next line contains the integer q, the number of queries. The next q lines each contain a destination junction-number. There can be at most one direct road from a junction to another junction.

Output

For each case, print the case number in a single line. Then print q lines, one for each query, each containing the minimum total earning when one travels from junction 1 (the zero point) to the given junction. However, for the queries that gives total earning less than 3, or if the destination is not reachable from the zero point, then print a '?'.

Sample Input

2

5
6 7 8 9 10
6
1 2
2 3
3 4
1 5
5 4
4 5
2
4
5

2
10 10
1
1 2
1
2

Sample Output 

Case 1:
3
4
Case 2:
?

问题描述:n个点,每个点有权值ai,从i到j的边权为:(aj−ai)^3。问从1到达k的最短路,不能到达和路径长小于3输出? 其它输出长度

解题思路:可能出现负环,使用SPFA算法,出现负环时,负环可达的结点都应该输出?,入队次数超过n次,标记它是负环中的结点,从此节点进行DFS,它所能达的结点的最短路径也为负无穷

AC的C++程序:

#include<iostream>
#include<cstring>
#include<cmath>
#include<queue>

using namespace std;

const int N=205;
const int INF=0x3f3f3f3f;
int dist[N],b[N];
int g[N][N];
bool vis[N];
bool f[N];//标记结点是否在负环中 
int cnt[N];
int n;

void dfs(int u)
{
	f[u]=true;
	for(int v=1;v<=n;v++)
	  if(!f[v]&&v!=u&&g[u][v]!=INF)
	    dfs(v);
}

void spfa(int s)
{
	memset(dist,INF,sizeof(dist));
	memset(vis,false,sizeof(vis));
	memset(f,false,sizeof(f));
	memset(cnt,0,sizeof(cnt));
	queue<int>q;
	vis[s]=true;
	cnt[s]=1;
	dist[s]=0;
	q.push(s);
	while(!q.empty()){
		int u=q.front();
		q.pop();
		vis[u]=false;
		if(!f[u]){//如果u不是负环中的点 
			for(int v=1;v<=n;v++)
			  if(!f[v]&&v!=u&&g[u][v]!=INF&&dist[v]>dist[u]+g[u][v]){
			  	dist[v]=dist[u]+g[u][v];
			  	if(!vis[v]){
			  		vis[v]=true;
			  		cnt[v]++;
			  		if(cnt[v]>n)//v是负环中的点 
			  		  dfs(v);//标记v可达的点也是负环中的点 
			  		else
			  		  q.push(v);
				  }
			  }
		}
	}
}

int main()
{
	int T,m,u,v,q,x;
	scanf("%d",&T);
	for(int t=1;t<=T;t++){
		scanf("%d",&n);
		memset(g,INF,sizeof(g));
		for(int i=1;i<=n;i++)
		  scanf("%d",&b[i]);
		scanf("%d",&m);
		while(m--){
			scanf("%d%d",&u,&v);
			g[u][v]=(b[v]-b[u])*(b[v]-b[u])*(b[v]-b[u]);
		}
		spfa(1);
		scanf("%d",&q);
		printf("Case %d:\n",t);
		while(q--){
			scanf("%d",&x);
			if(f[x]||dist[x]==INF||dist[x]<3)
			  printf("?\n");
			else
			  printf("%d\n",dist[x]);
		}
	}
	return 0;
}
 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值