HDU1384 Intervals【差分约束】

Intervals

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5200    Accepted Submission(s): 1916


 

Problem Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.

Write a program that:

> reads the number of intervals, their endpoints and integers c1, ..., cn from the standard input,

> computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i = 1, 2, ..., n,

> writes the answer to the standard output

Input

The first line of the input contains an integer n (1 <= n <= 50 000) - the number of intervals. The following n lines describe the intervals. The i+1-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50 000 and 1 <= ci <= bi - ai + 1.

Process to the end of file.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i = 1, 2, ..., n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

Author

1384

问题链接:HDU1384 Intervals

解题思路:差分约束,化成 Xi-Xj>=w 的形式,建立一条从j到i的权值为-w的边,求最小值,建图后求最长路

AC的C++程序:

#include<iostream>
#include<cstring>
#include<vector> 
#include<queue>

using namespace std;

const int N=50100;
const int INF=0x3f3f3f3f;

struct Edge{
	int v,w;
	Edge(int v,int w):v(v),w(w){}
};

vector<Edge>g[N];

bool vis[N];
int dist[N];

void spfa(int s)
{
	queue<int>q;
	memset(vis,false,sizeof(vis));
	memset(dist,INF,sizeof(dist));
	vis[s]=true;
	dist[s]=0;
	q.push(s);
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=false;
		for(int i=0;i<g[u].size();i++)
		{
			int v=g[u][i].v;
			int w=g[u][i].w;
			if(dist[v]>dist[u]+w)
			{
				dist[v]=dist[u]+w;
				if(!vis[v])
				{
					vis[v]=true;
					q.push(v);
				}
			}
		}
	}
}

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		for(int i=0;i<N;i++)
		  g[i].clear();
		int a,b,w,s=N,e=0;
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d%d",&a,&b,&w);
			a++,b++;
			s=min(s,a);
			e=max(e,b);
			g[a-1].push_back(Edge(b,-w));
		}
		//限制条件
		for(int i=s-1;i<=e;i++)
		{
			g[i].push_back(Edge(i+1,0));
			g[i+1].push_back(Edge(i,1));
		}
		s--; //最小的顶点编号 
		spfa(s);
		printf("%d\n",-dist[e]); 
	}
	return 0;
}
 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值