Equivalent Sets
Time Limit: 12000/4000 MS (Java/Others) Memory Limit: 104857/104857 K (Java/Others)
Total Submission(s): 6246 Accepted Submission(s): 2239
Problem Description
To prove two sets A and B are equivalent, we can first prove A is a subset of B, and then prove B is a subset of A, so finally we got that these two sets are equivalent.
You are to prove N sets are equivalent, using the method above: in each step you can prove a set X is a subset of another set Y, and there are also some sets that are already proven to be subsets of some other sets.
Now you want to know the minimum steps needed to get the problem proved.
Input
The input file contains multiple test cases, in each case, the first line contains two integers N <= 20000 and M <= 50000.
Next M lines, each line contains two integers X, Y, means set X in a subset of set Y.
Output
For each case, output a single integer: the minimum steps needed.
Sample Input
4 0
3 2
1 2
1 3
Sample Output
4
2
Hint
Case 2: First prove set 2 is a subset of set 1 and then prove set 3 is a subset of set 1.
Source
2011 Multi-University Training Contest 1 - Host by HNU
解题思路:此题与 HDU2767 Proving Equivalences 一样,只是输入格式有细微区别。
AC的C++程序:
#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
#include<stack>
using namespace std;
const int N=20005;
bool flag[N];
int dfn[N],low[N],index;
int in[N],out[N];//缩点后的新图各点的入度和出度
int belong[N];//记录原图个点所属的强连通分量的编号
int cnt;//强连通分量的个数
int n,m;
vector<int>g[N];
stack<int>s;
void Tarjan(int u)
{
dfn[u]=low[u]=++index;
s.push(u);
flag[u]=true;
for(int i=0;i<g[u].size();i++)
{
int v=g[u][i];
if(!dfn[v])
{
Tarjan(v);
low[u]=min(low[u],low[v]);
}
else if(flag[v])
low[u]=min(low[u],dfn[v]);
}
if(dfn[u]==low[u])
{
cnt++;
int v;
do{
v=s.top();
s.pop();
flag[v]=false;
belong[v]=cnt;
}while(v!=u);
}
}
void solve()
{
for(int i=0;i<=n;i++)
dfn[i]=low[i]=in[i]=out[i]=belong[i]=flag[i]=0;
cnt=index=0;
while(!s.empty()) s.pop();
for(int i=1;i<=n;i++)
if(!dfn[i])
Tarjan(i);
//统计缩点后各个节点的入度和出度
for(int u=1;u<=n;u++)
for(int i=0;i<g[u].size();i++)
{
int v=g[u][i];
if(belong[u]!=belong[v])
{
out[belong[u]]++;
in[belong[v]]++;
}
}
if(cnt==1)//只有一个强连通分量,不用加边
{
printf("0\n");
return;
}
int num1=0,num2=0;//统计入度和出度为0的节点的个数
for(int i=1;i<=cnt;i++)
{
if(in[i]==0)
num1++;
if(out[i]==0)
num2++;
}
printf("%d\n",max(num1,num2));//添加的边数为num1和num2的较大者
}
int main()
{
int a,b;
while(~scanf("%d%d",&n,&m))
{
for(int i=0;i<=n;i++)
g[i].clear();
while(m--)
{
scanf("%d%d",&a,&b);
g[a].push_back(b);
}
solve();
}
return 0;
}