HDU2767 Proving Equivalences【有向图强连通分支+缩点】

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9356    Accepted Submission(s): 3302


 

Problem Description

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0. 

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output

Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2
4 0
3 2
1 2
1 3

Sample Output

4
2

Source

NWERC 2008

问题链接:HDU2767 Proving Equivalences

问题描述:给定一张有向图,问最少添加几条边使得有向图成为一个强连通图。

解题思路:用Tarjan算法进行缩点,然后就变成一个有向无环图(DAG)了。 我们要考虑的问题是让它变成强连通,让DAG变成强连通就是把尾和头连起来,也就是入度和出度为0的点。统计DAG入度和出度,然后计算头尾,最大的那个就是所求。

AC的C++程序:

#include<iostream>
#include<cstring>
#include<algorithm>
#include<vector>
#include<stack>

using namespace std;

const int N=20005;

bool flag[N];
int dfn[N],low[N],index;
int in[N],out[N];//缩点后的新图各点的入度和出度
int belong[N];//记录原图个点所属的强连通分量的编号
int cnt;//强连通分量的个数
int n,m;

vector<int>g[N];
stack<int>s;

void Tarjan(int u)
{
	dfn[u]=low[u]=++index;
	s.push(u);
	flag[u]=true;
	for(int i=0;i<g[u].size();i++)
	{
		int v=g[u][i];
		if(!dfn[v])
		{
			Tarjan(v);
			low[u]=min(low[u],low[v]);
		}
		else if(flag[v])
		  low[u]=min(low[u],dfn[v]);
	}
	if(dfn[u]==low[u])
	{
		cnt++;
		int v;
		do{
			v=s.top();
			s.pop();
			flag[v]=false;
			belong[v]=cnt;
		}while(v!=u);
	}
}

void solve()
{
	for(int i=0;i<=n;i++)
	  dfn[i]=low[i]=in[i]=out[i]=belong[i]=flag[i]=0;
	cnt=index=0;
	while(!s.empty()) s.pop();
	for(int i=1;i<=n;i++)
	  if(!dfn[i])
	    Tarjan(i);
	//统计缩点后各个节点的入度和出度
	for(int u=1;u<=n;u++)
	  for(int i=0;i<g[u].size();i++)
	  {
	  	int v=g[u][i];
	  	if(belong[u]!=belong[v])
	  	{
	  		out[belong[u]]++;
	  		in[belong[v]]++;
		}
	   } 
	if(cnt==1)//只有一个强连通分量,不用加边 
	{
		printf("0\n");
		return;
	}
	int num1=0,num2=0;//统计入度和出度为0的节点的个数 
	for(int i=1;i<=cnt;i++)
	{
		if(in[i]==0)
		  num1++;
		if(out[i]==0)
		  num2++;
	}
	printf("%d\n",max(num1,num2));//添加的边数为num1和num2的较大者 
}

int main()
{
	int t,a,b;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=0;i<=n;i++)
		  g[i].clear();
		while(m--)
		{
			scanf("%d%d",&a,&b);
			g[a].push_back(b);
		}
		solve();
	}
	return 0;
}
 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值