POJ2689 Prime Distance【区间筛法】

http://poj.org/problem?id=2689

Prime Distance

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26286 Accepted: 6798

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source

Waterloo local 1998.10.17

题意

给出一个区间[L,U],找出区间内容、相邻的距离最近的两个素数和距离最远的两个素数。

思路

区间筛法

C++代码

#include<iostream>
#include<cstring>

using namespace std;

const int N1=500010;
const int N2=1000010;

int prime[N1+1];
int f[N2+1];

//使用欧拉筛计算出<=n的素数,并存放在prime数组中 
void maketable(int n)
{
	for(int i=2;i<=n;i++)
	{
		if(!prime[i]) prime[++prime[0]]=i;
		for(int j=1;j<=prime[0]&&prime[j]<=n/i;j++)
		{
			prime[prime[j]*i]=1;
			if(i%prime[j]==0)
			  break;
		}
	}
}

//区间筛,计算出区间[l,r]中的素数,并存放在f函数中
int tot;
 
void solve(int l,int r)
{
	memset(f,0,sizeof(f));
	if(l==1) f[0]=1;//特判 1 
	for(int i=1;i<=prime[0];i++)
	{
		int a=(l-1)/prime[i]+1,b=r/prime[i];
		for(int j=a;j<=b;j++)
		{
			if(j>1) f[j*prime[i]-l]=1;
		}
	}
	tot=0;
	for(int i=0;i<=r-l;i++)
	  if(!f[i])
	  	f[tot++]=i;
}

int main()
{
	int l,r;
	maketable(N1);
	while(~scanf("%d%d",&l,&r))
	{
		solve(l,r);
		if(tot<=1)
		  printf("There are no adjacent primes.\n");
		else
		{
			int a=1,b=1;
			for(int i=2;i<tot;i++)
			{
				if(f[i]-f[i-1]<f[a]-f[a-1])
				  a=i;
				if(f[i]-f[i-1]>f[b]-f[b-1])
				  b=i;
			}
			printf("%d,%d are closest, %d,%d are most distant.\n",f[a-1]+l,f[a]+l,f[b-1]+l,f[b]+l);
		}		
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值