POJ3494 Largest Submatrix of All 1’s【单调栈 01矩阵中最大的1矩形】

Largest Submatrix of All 1’s

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 8502 Accepted: 3075
Case Time Limit: 2000MS

Description

Given a m-by-n (0,1)-matrix, of all its submatrices of all 1’s which is the largest? By largest we mean that the submatrix has the most elements.

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ mn ≤ 2000) on line. Then come the elements of a (0,1)-matrix in row-major order on m lines each with n numbers. The input ends once EOF is met.

Output

For each test case, output one line containing the number of elements of the largest submatrix of all 1’s. If the given matrix is of all 0’s, output 0.

Sample Input

2 2
0 0
0 0
4 4
0 0 0 0
0 1 1 0
0 1 1 0
0 0 0 0

Sample Output

0
4

Source

POJ Founder Monthly Contest – 2008.01.31, xfxyjwf

题意

在一个M * N的矩阵中,所有的元素只有0和1, 找出只包含1的最大矩形。

思路

先对矩阵进行预处理,使得a[i][j]表示以位置(i,j)为起点,往下即(i,j+1)、(i,j+2)、...中最长的连续1的长度,例如

\begin{bmatrix} 0 & 0 &0 &0 \\ 0& 1 & 1 &0 \\ 0&1 & 1 &0 \\ 0& 0&0 &0 \end{bmatrix}\Rightarrow \begin{bmatrix} 0 & 0 & 0&0 \\ 0 & 2 & 2&0 \\ 0 & 1 & 1&0 \\ 0 & 0 & 0 &0 \end{bmatrix}

预处理后,我们单独分析每一行,第二行0 2 2 0表示四个元素向下连续的1的长度分别为0 2 2 0,问题就转化为用单调栈求最大矩形的面积了,只要枚举每个元素,并统计以它为最小值的最大区间的长度即可,用长度乘以这个最小值就是面积,遍历m行后,答案就出来了。

C++代码

#include<iostream>
#include<cstring>

using namespace std;

const int N=2005;

int a[N][N];
int l[N],s[N];

int main()
{
	int n,m;
	while(~scanf("%d%d",&m,&n))
	{
		memset(a,0,sizeof(a));
		//读入 
		for(int i=1;i<=m;i++)
		  for(int j=1;j<=n;j++)
		    scanf("%d",&a[i][j]);
		//预处理 
		for(int i=1;i<=n;i++)
		  for(int j=m;j>=1;j--)
		  	if(a[j][i]) a[j][i]+=a[j+1][i];
		
		int ans=0;
		for(int i=1;i<=m;i++)//考虑第i行 
		{
			a[i][n+1]=-1;
			int top=0;
			//维护一个递增栈 
			for(int j=1;j<=n+1;j++)
			{
				l[j]=j;
				while(top>0&&a[i][s[top]]>a[i][j])
				{
					ans=max(ans,a[i][s[top]]*(j-l[s[top]]));
					l[j]=l[s[top]];
					top--;
				}
				if(top>0&&a[i][s[top]]==a[i][j]) l[j]=l[s[top]];
				s[++top]=j;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值