HDU5536 Chip Factory【01字典树】

Chip Factory

http://acm.hdu.edu.cn/showproblem.php?pid=5536

Time Limit: 18000/9000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 6523    Accepted Submission(s): 2938


 

Problem Description

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:

maxi,j,k(si+sj)⊕sk


which i,j,k are three different integers between 1 and n. And ⊕ is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?

 

Input

The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,..,sn, separated with single space, indicating serial number of each chip.

1≤T≤1000
3≤n≤1000
0≤si≤10^9
There are at most 10 testcases with n>100

 

Output

For each test case, please output an integer indicating the checksum number in a line.

 

Sample Input

2
3
1 2 3
3
100 200 300

Sample Output

6
400

Source

2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

题意

在一个数组中找出(s[i]+s[j])^s[k]最大的值,其中i、j、k各不同

思路

01字典树,要保证不同,使用一个num数组保证i、j、k各不同

C++代码

#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;

const int N=1050;
int s[N];
int trie[32*N][2];
int val[32*N];
int num[32*N];
int tot;

void insert(int x,int v)
{
	int rt=0;
	for(int i=31;i>=0;i--)
	{
		int c=(x>>i)&1;
		if(!trie[rt][c]) trie[rt][c]=++tot;
		rt=trie[rt][c];
		num[rt]+=v;
	}
	val[rt]=x;
}

int find(int x)
{
	int rt=0;
	for(int i=31;i>=0;i--)
	{
		int c=(x>>i)&1;
		if(trie[rt][c^1]&&num[trie[rt][c^1]]>0)
		  rt=trie[rt][c^1];
		else
		  rt=trie[rt][c];
	}
	return val[rt];
}

int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		tot=0;
		memset(trie,0,sizeof(trie));
		memset(val,0,sizeof(val));
		memset(num,0,sizeof(val));
		
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&s[i]);
			insert(s[i],1);
		}
		int ans=0;
		for(int i=1;i<=n;i++)
		  for(int j=i+1;j<=n;j++)
		  {
		  	int x=s[i]+s[j];
		  	//在字典树中清除s[i]和s[j]的记录,保证i,j,k互异
			insert(s[i],-1);
			insert(s[j],-1);
			ans=max(ans,x^find(x));
			//恢复s[i]和s[j]的记录
			insert(s[i],1);
			insert(s[j],1);
		  }
		printf("%d\n",ans);
	}
	return 0; 
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值