Chip Factory HDU - 5536

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:
maxi,j,k(si+sj)⊕sk

which i,j,k are three different integers between 1 and n. And ⊕
is symbol of bitwise XOR.

Can you help John calculate the checksum number of today? 

Input
The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,..,sn, separated with single space, indicating serial number of each chip.

1≤T≤1000
3≤n≤1000
0≤si≤109
There are at most 10 testcases with n>100
Output
For each test case, please output an integer indicating the checksum number in a line.
Sample Input

2
3
1 2 3
3
100 200 300

Sample Output

6
400
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
long long int a[1010];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        long long int xx=0;
        //int sum=0;
        for (int i=0; i<n; i++)
        {
            scanf("%lld",&a[i]);
        }
        for (int i=0; i<n; i++)
        {
            for (int j=i+1; j<n; j++)
            {
                for  (int q=j+1; q<n; q++)
                {
                    xx=max(xx,(a[i]+a[j])^a[q]);
                    xx=max(xx,(a[i]+a[q])^a[j]);
                    xx=max(xx,(a[j]+a[q])^a[i]);
                }
            }
        }
        printf("%lld\n",xx);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值