hdu---1084What Is Your Grade?

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7589    Accepted Submission(s): 2345


Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam! 
Come on!
 

 

Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 

 

Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 

 

Sample Input
4 5 06:30:17 4 07:31:27 4 08:12:12 4 05:23:13 1 5 06:30:17 -1
 

 

Sample Output
100 90 90 95 100
 
 
 
AC代码:
/*
    水题一枚,不卡时,完全模拟求出结果即可; 这里作为一次代码练习。
    题目中注意两个细节:
    一个是每个样例后都有一个空行;
    另一个是当只有一个人做出4题时,是95分,不是90分,这点题目描述没说清楚。
    细节很重要,这两个点也卡了我20分钟,还是比较浪费时间的。
*/
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#define N 110
typedef struct LNode{
    int num;
    int t;
    int a,b,c;
    int sorce;
}LNode;
LNode f[N];
void cmd(LNode f[N],int n);

int main()
{
    int i,j,k=0;int flag=0;
    freopen("in.txt","r",stdin);
    int n,m;
    while(scanf("%d",&n)){
        if(n==-1) break;

        for(i=0;i<n;i++){
            scanf("%d %d:%d:%d",&f[i].t,&f[i].a,&f[i].b,&f[i].c);
            f[i].num=i+1;//一开始的顺序!
        }
        cmd(f,n);//排序
        for(i=0;i<n;i++)
            if(f[i].t==5) f[i].sorce=100;
            else break;
        j=i; //第j-1个为做对4题;
        m=4; int fen=90;
        while(m){
            int num=0;
            for(i=j;i<n;i++){
                if(f[i].t==m) num++;
                else break;
            }
            int kk=i;
            k=num/2;  //k个+5分的;
            if(num==1) k=1;
            for(i=j;i<j+num;i++){
                if(k){
                    f[i].sorce=fen+5;
                    k--;
                }
                else f[i].sorce=fen;
            }
            j=kk;
            fen=fen-10;
            m--;
        }//前面5-1的统计完毕!  下面统计没做出题目的;
        for(i=j;i<n;i++)
            f[i].sorce=50;
        LNode p;
        for(i=0;i<n;i++)
            for(j=0;j<n-i-1;j++){
                if(f[j].num>f[j+1].num){
                    p=f[j];f[j]=f[j+1];f[j+1]=p;
                }
            }
        for(i=0;i<n;i++)
            printf("%d\n",f[i].sorce);
        printf("\n");
    }
    return 0;
}

void cmd(LNode f[N],int n){
    int i,j,k;LNode m;
    for(i=0;i<n;i++)
        for(j=0;j<n-i-1;j++)
            if(f[j].t<f[j+1].t){
                m=f[j];f[j]=f[j+1];f[j+1]=m;
            }
            else if(f[j].t==f[j+1].t){
                if(f[j].a>f[j+1].a){
                    m=f[j];f[j]=f[j+1];f[j+1]=m;
                }
                else if(f[j].a==f[j+1].a){
                    if(f[j].b>f[j+1].b){
                        m=f[j];f[j]=f[j+1];f[j+1]=m;
                    }
                    else if(f[j].b==f[j+1].b){
                        if(f[j].c>f[j+1].c){
                            m=f[j];f[j]=f[j+1];f[j+1]=m;
                        }
                    }
                }
            }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值