hdu---2069Coin Change

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12382    Accepted Submission(s): 4141


Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 

 

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

 

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

 

Sample Input
11 26
 

 

Sample Output
4 13
 
//一道深搜的题目!  与一般的深搜不同的是,这里的每个硬币可以使用多个!
//一开始不知道怎么处理,很多重复的情况;后来是加了一个参数变量y,来防止重复。
//另外因为Your program should be able to handle up to 100 coins.这句话没注意,wa了一次。
Code:
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
int n;int t;
int f[6]={0,50,25,10,5,1};
void d(int num,int y,int z){
    int i;
    if(num==0 && z<=100){
        t++; return ;
    }
    z++;
    for(i=1;i<=5;i++){
        if(num>=f[i] && f[i]>=y){
            //d(num+f[i],k);
            d(num-f[i],f[i],z);
        }
    }
}
int main()
{
    freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int i,j,k;
    while(scanf("%d",&n)!=EOF){
        t=0;
        d(n,0,0);
        printf("%d\n",t);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值