SDNUOJ 1656.Changing a Character

Time Limit: 1000 MS    Memory Limit: 32768 KB
Total Submission(s): 110    Accepted Submission(s): 90

Description

You are given a string SS of length NN consisting of AB and C, and an integer KK which is between 11 and NN (inclusive). Print the string SS after lowercasing the KK-th character in it.

  • 1≤N≤501≤N≤50
  • 1≤K≤N1≤K≤N
  • SS is a string of length NN consisting of AB and C.

Input

Input is given from Standard Input in the following format:

NN KK
SS

Output

Print the string SS after lowercasing the KK-th character in it.

Sample Input

3 1
ABC

Sample Output

aBC

Source

Unknown

key:水题

附上AC代码:

#include<bits/stdc++.h>
using namespace std;
char c,d;
int n=0,k=0,i=0;
int main()
{
	cin>>n>>k;
	for(i=0;i<n;i++)
	{
		cin>>c;
		if(i==k-1)
		{
			d=c+32;
			cout<<d;
			continue;
		}
		cout<<c;
		
	}
	cout<<'\n';
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值