DNA sequence(HDU - 1560)

The twenty-first century is a biology-technology developing century. We know that a gene is made of DNA. The nucleotide bases from which DNA is built are A(adenine), C(cytosine), G(guanine), and T(thymine). Finding the longest common subsequence between DNA/Protein sequences is one of the basic problems in modern computational molecular biology. But this problem is a little different. Given several DNA sequences, you are asked to make a shortest sequence from them so that each of the given sequence is the subsequence of it.

For example, given “ACGT”,“ATGC”,“CGTT” and “CAGT”, you can make a sequence in the following way. It is the shortest but may be not the only one.
在这里插入图片描述

Input
The first line is the test case number t. Then t test cases follow. In each case, the first line is an integer n ( 1<=n<=8 ) represents number of the DNA sequences. The following k lines contain the k sequences, one per line. Assuming that the length of any sequence is between 1 and 5.
Output
For each test case, print a line containing the length of the shortest sequence that can be made from these sequences.
Sample Input
1
4
ACGT
ATGC
CGTT
CAGT
Sample Output
8

思路
IDA*算法(迭代加深算法),详见代码注释

#include <iostream>
#include <string>
#include <cstring>
using namespace std;

int n;
char dna[4]={'A','T','C','G'};
string s[10];
int pos[10];///字串在所给串中匹配到的位置
int len[10];///字串的长度
int maxn;///所求串最短的长度

int geth()///h()函数,所求串最少还要在增长多少
{
    int m=0;
    for(int i=1;i<=n;i++)
        m=max(m,len[i]-pos[i]);///len-pos得出字串未匹配的长度
    return m;
}

bool solve(int dep)///dfs
{
    if(dep+geth()>maxn) return false;
    if(!geth()) return true;
    int temp[10];
    memcpy(temp,pos,sizeof(pos));///将pos拷贝到temp中,方便回溯
    for(int i=0;i<4;i++)
    {
        int sign=0;
        for(int j=1;j<=n;j++)
            ///答案串加入dna[i],与第j个字串的pos[j]匹配,则pos[j]++
            if(s[j][pos[j]]==dna[i])
                sign=1,pos[j]++;
        if(sign)///答案串新加入的dna[i]有与字串匹配的,则往下一层搜索
        {
            if(solve(dep+1)) return true;///下一层符合,返回
            memcpy(pos,temp,sizeof(pos));///回溯
        }
    }
    return false;
}

int IDA_Star()///IDA*算法,迭代加深,直到满足题意
{
    while(!solve(0)) maxn++;
    return maxn;
}

int main()
{
    int t;cin>>t;
    while(t--)
    {
        memset(pos,0,sizeof(pos));
        memset(len,0,sizeof(len));
        cin>>n;
        for(int i=1;i<=n;i++) cin>>s[i],len[i]=s[i].size();
        maxn=0;
        IDA_Star();
        cout<<maxn<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值