hdu1698-线段树模板

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

在这里插入图片描述

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input
1
10
2
1 5 2
5 9 3

Sample Output
Case 1: The total value of the hook is 24.

自从上次被说线段树板子很丑之后,就一直想找个时间自己整理一下。所以就搞了个自己看上去还行的板子。

AC代码

#include<bits/stdc++.h>
#define outtime() cerr<<"User Time = "<<(double)clock()/CLOCKS_PER_SEC<<endl
using namespace std;
const int N = 1e5 +10;
int n, m, a[N], T, t;
struct SEG{
	int t[N << 2], lazy[N << 2];
	
	void up(int id){
		t[id] = t[id << 1] + t[id << 1 | 1];
	}
	
	void build(int id, int l, int r){
		t[id] = 0;
		lazy[id] = 0;
		if(l == r){
			t[id] = 1;
			return;
		}
		int mid = (l + r) >> 1;
		build(id << 1, l, mid);
		build(id << 1 | 1, mid + 1, r);
		up(id);
	}
	
	void down(int id, int sz){
		if(!lazy[id]) return;
		lazy[id << 1] = lazy[id];
		lazy[id << 1 | 1] = lazy[id];
		t[id << 1] = lazy[id] * (sz - (sz >> 1));
		t[id << 1 | 1] = lazy[id] * (sz >> 1);
		lazy[id] = 0;
	}
	
	void modify(int id, int l,int r, int ql, int qr, int v){
		if(ql <= l && r <= qr){
			lazy[id] = v;
			t[id] = (r - l + 1) * v;
			return;
		}
		down(id, (r - l + 1));
		int mid = (l + r) >> 1;
		if(qr <= mid) modify(id << 1, l, mid, ql, qr, v);
		else if(ql > mid) modify(id << 1 | 1, mid + 1, r, ql, qr, v);
		else{
			modify(id << 1, l, mid, ql, qr, v);
			modify(id << 1 | 1, mid + 1, r, ql, qr, v);
		}
		up(id);
	}
	
	int getsum(int id, int l, int r, int ql, int qr){
		if(l >= ql && r <= qr) return t[id];
		down(id, (r - l + 1));
		int mid = (l + r) >> 1;	
		if(qr <= mid) return getsum(id << 1, l, mid, ql, qr);
		else if(ql > mid) return getsum(id << 1 | 1, mid+1, r, ql, qr);
		else return getsum(id << 1, l, mid, ql, qr) + getsum(id << 1 | 1, mid+1, r, ql, qr);
	}
}seg;
int ql, qr, v;
void solve(){
	scanf("%d", &n);
	scanf("%d", &m);
	seg.build(1, 1, n);
	while(m--){
		scanf("%d%d%d",&ql, &qr, &v);
		seg.modify(1, 1, n, ql, qr, v);
	}
	printf("Case %d: The total value of the hook is %d.\n", t, seg.getsum(1, 1, n, 1, n));
}
int main(){
	scanf("%d",&T);
	for(t = 1; t <= T; ++t)
		solve();
	return 0;
}

从薛佬那里偷来的原板子

struct SEG{
	int t[N << 2];
	void build(int id, int l, int r){
		t[id] = 0;
		if(l == r) return;
		int mid = (l + r) >> 1;
		build(id << 1 , l, mid);
		build(id << 1 | 1, mid + 1, r);
	}
	void down(int id){
		if(t[id] == -1) return;
		t[id << 1] = t[id];
		t[id << 1 | 1] = t[id];
		t[id] = -1;
	}
	void modify(int id, int l, int r, int ql, int qr , int v){
		if(l >= ql && r <= qr){
			t[id] = v;
			return;
		}
		down(id);
		int mid = (r + l) >> 1;
		if(ql <= mid) modify(id << 1, l, mid, ql, qr, v);
		if(qr > mid) modify(id << 1 | 1, mid + 1, r, ql, qr, v);
	}
	int query(int id, int l, int r, int p){
		if(l == r) return t[id];
		int mid = (l + r) >> 1;
		down(id);
		if(p <= mid) return query(id << 1, l, mid, p);
		else return query(id << 1 | 1, mid + 1, r, p);
	}
}seg;
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值