hdu1698(线段树入门)

Problem Description
In the game of DotA, Pudge’s meat hook is actually
the most horrible thing for most of the heroes. The hook is made up of
several consecutive metallic sticks which are of the same length.
Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N.
For each operation, Pudge can change the consecutive metallic sticks,
numbered from X to Y, into cupreous sticks, silver sticks or golden
sticks. The total value of the hook is calculated as the sum of values
of N metallic sticks. More precisely, the value for each kind of stick
is calculated as follows:

For each cupreous stick, the value is 1. For each silver stick, the
value is 2. For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the
operations. You may consider the original hook is made up of cupreous
sticks.

Input The input consists of several test cases. The first line of the
input is the number of the cases. There are no more than 10 cases. For
each case, the first line contains an integer N, 1<=N<=100,000, which
is the number of the sticks of Pudge’s meat hook and the second line
contains an integer Q, 0<=Q<=100,000, which is the number of the
operations. Next Q lines, each line contains three integers X, Y,
1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks
numbered from X to Y into the metal kind Z, where Z=1 represents the
cupreous kind, Z=2 represents the silver kind and Z=3 represents the
golden kind.

Output For each case, print a number in a line representing the total
value of the hook after the operations. Use the format in the example.

Sample Input
1 10 2 1 5 2 5 9 3
Sample Output
Case 1: The total value of the hook is 24.

题目大意:
给定一个序列n,再进行q次更新,每次把[x,y]区间内的值全都赋值为z,问最后序列的总和
注意,序列初始全部赋值为1
思路:
一个区间修改+区间查询的题目,我首先想到的是树状数组来解决,但是发现是区间赋值,树状数组解决不了,所以只能用线段树来解决了,这个题目就是一个入门题,可以直接套用模板即可
代码:
这里甚至都不用查询函数,直接输出第一个节点的sum值即可,要注意的是,参数比较多 ,不要搞混了

#include <bits/stdc++.h>

using namespace std;
const int maxn=100005;
int n,q,t,cas=1;
int tree[maxn<<2],lazy[maxn<<2];
void pushUp(int k)//更新当前节点的值
{
    tree[k] = tree[k<<1] + tree[k<<1|1];
}

void build(int l,int r,int k)
{
    if(l==r)
    {
        tree[k]=1;
        return;
    }
    int mid=(l+r)>>1;
    build(l,mid ,k<<1 );
    build( mid+1, r , k<<1|1);
    pushUp(k);
}
void pushDown(int k,int ln,int rn)
{
    if(lazy[k])//如果有lazy标签
    {

        lazy[k<<1]   = lazy[k];
        lazy[k<<1|1] = lazy[k];
        tree[k<<1] = lazy[k]*ln ;//[l,mid]
        tree[k<<1|1] = lazy[k]*rn ;//[mid+1,r]
        lazy[k]=0;
    }
}
//[l,r]区间内的修改,[L,R]当前区间
void update(int x,int l,int r,int k,int L,int R)
{
    if(l<=L && r>=R)
    {
        tree[k]=(R-L+1)*x;
        lazy[k]=x;
        return ;
    }
    int mid=(L+R)>>1;
    pushDown(k,mid-L+1,R-mid);//下传lazy

    if(l<=mid) update(x,l,r, k<<1   ,L     ,mid);
    if(r>mid)  update(x,l,r, k<<1|1 ,mid+1 ,R);

    pushUp(k);//子节点更新完后,把自己更新一下

}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(tree,0,sizeof(tree));
        memset(lazy,0,sizeof(lazy));
        scanf("%d%d",&n,&q);
        build(1,n,1);//建树
        while(q--)
        {
            int x,y,z;
            scanf("%d %d %d",&x,&y,&z);
            update(z,x,y,1,1,n);
        }
        printf("Case %d: The total value of the hook is %d.\n",cas++,tree[1]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值