hduoj1002,A + B Problem II, 大数加法,经典

A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

分析:
前期代码能力很挫,string类型一点都不会,基本还是C的方式。
算法分析:
将输入的两个数用字符串存储,然后逆序存入两个整形数组中。
第一个数组每一项与另一个数组的对应项相加,大于等于10就将个位存入原数组,后一项即高一位加1,知道处理结束。
输出时注意起点。
code:
#include<iostream>
#include<string>
#define MAX_LEN 1000
using namespace std;
int num1[MAX_LEN+10];
int num2[MAX_LEN+10];
char Str1[MAX_LEN+10];
char Str2[MAX_LEN+10];
int main()
{
    int n,i,j,time=0;
    cin>>n;
    while(n--)
    {
        time++;
        cin>>Str1>>Str2;
        memset(num1,0,sizeof(num1));
        memset(num2,0,sizeof(num2));
        int Len1=strlen(Str1),Len2=strlen(Str2);
        for(i=Len1-1,j=0;i>=0;i--)
            num1[j++]=Str1[i]-'0';
        for(i=Len2-1,j=0;i>=0;i--)
            num2[j++]=Str2[i]-'0';
        for(i=0;i<MAX_LEN;i++)
        {
            num1[i]+=num2[i];
            if(num1[i]>=10)
            {
                num1[i]-=10;
                num1[i+1]++;
            }
        }
        cout<<"Case "<<time<<":"<<endl;
        for(i=0;i<Len1;i++)
            cout<<Str1[i];
        cout<<" + ";
        for(i=0;i<Len2;i++)
            cout<<Str2[i];
        cout<<" = ";
        bool bStartOutPut=false;
        for(i=MAX_LEN;i>=0;i--)
        {
            if(bStartOutPut)
                printf("%d",num1[i]);
            else if(num1[i])
            {
                printf("%d",num1[i]);
                bStartOutPut=true;
            }
        }
        if(n!=0)
            cout<<endl<<endl;
        else
            cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值