POJ3295,Tautology,看到分类是构造法吓住了,主要是递归

Tautology

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.


Input


Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.


Output


For each test case, output a line containing tautology or not as appropriate.


Sample Input

ApNp
ApNq
0
 

Sample Output

tautology
not


分析:

题意即是数理逻辑里的什么命题的条件关系等于关系等。

一共就5个变量,32种情况直接暴力枚举。

考虑计算,递归地把后面的一行命题看成一个变量,注意不能用逻辑的||,&&,这样会出现短路的情况,pos值改变就不对,应该使用|,&位运算。。。其实我也第一次听说。


code:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include<string>
using namespace std;
char wff[100+5];
int pos,p,q,r,s,t;
bool cal()
{
    pos++;
    switch(wff[pos])
    {
        case 'p': return p;
        case 'q': return q;
        case 'r': return r;
        case 's': return s;
        case 't': return t;
        case 'K': return cal()&cal();
        case 'A': return cal()|cal();
        case 'N': return !cal();
        case 'C': return (!cal())|cal();
        case 'E': return cal()==cal();
    }
}
int main()
{
    bool flag;
    while(gets(wff),wff[0]!='0')
    {
        flag=true;
        for(p=0;p<2&&flag;p++)
        for(q=0;q<2&&flag;q++)
        for(r=0;r<2&&flag;r++)
        for(s=0;s<2&&flag;s++)
        for(t=0;t<2&&flag;t++)
        {
            pos=-1;
            flag=cal();
        }
        if(flag) printf("tautology\n");
        else printf("not\n");
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值